aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnomefind/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-06-06 20:52:06 +0800
committersobomax <sobomax@FreeBSD.org>2000-06-06 20:52:06 +0800
commit64c01a3b3a34e121bc2bb8ffd34a4bd3a379ea5a (patch)
tree6a1b4d6518a930830435b45d3ece7ab9808f1512 /sysutils/gnomefind/Makefile
parentd47f70bff06818ffa7746ac3739fcd0532e2f8c8 (diff)
downloadfreebsd-ports-gnome-64c01a3b3a34e121bc2bb8ffd34a4bd3a379ea5a.tar.gz
freebsd-ports-gnome-64c01a3b3a34e121bc2bb8ffd34a4bd3a379ea5a.tar.zst
freebsd-ports-gnome-64c01a3b3a34e121bc2bb8ffd34a4bd3a379ea5a.zip
Initial import of gnomefind - a Gnome'fied version of GNU find utility (not a
frontend).
Diffstat (limited to 'sysutils/gnomefind/Makefile')
-rw-r--r--sysutils/gnomefind/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/gnomefind/Makefile b/sysutils/gnomefind/Makefile
new file mode 100644
index 000000000000..6cd712730409
--- /dev/null
+++ b/sysutils/gnomefind/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnomefind
+# Date created: 26 May 2000
+# Whom: Maxim Sobolev
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomefind
+PORTVERSION= 0.4
+CATEGORIES= sysutils gnome
+MASTER_SITES= http://download.sourceforge.net/gnome-find/
+DISTNAME= gnome-find-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ glade.3:${PORTSDIR}/devel/libglade
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-lgnuregex -L${LOCALBASE}/lib"
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+MAN1= gnome-find.1
+
+.include <bsd.port.mk>