aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gstopd/Makefile
diff options
context:
space:
mode:
authormr <mr@FreeBSD.org>2003-10-19 01:28:13 +0800
committermr <mr@FreeBSD.org>2003-10-19 01:28:13 +0800
commit093d3a605d56d64d079bbaa6f76c25056f02e78b (patch)
treebb53dbc37dab6506f4e11f7632452f586dbbeb87 /sysutils/gstopd/Makefile
parentcef18bdb08c6e51242983a305216e273f7e320a1 (diff)
downloadfreebsd-ports-gnome-093d3a605d56d64d079bbaa6f76c25056f02e78b.tar.gz
freebsd-ports-gnome-093d3a605d56d64d079bbaa6f76c25056f02e78b.tar.zst
freebsd-ports-gnome-093d3a605d56d64d079bbaa6f76c25056f02e78b.zip
Add gstopd to the ports.
gstopd stops disks (da(4) currently) after some amount of inactivity. The inactivity is measured using GEOM(4) statistics.
Diffstat (limited to 'sysutils/gstopd/Makefile')
-rw-r--r--sysutils/gstopd/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/gstopd/Makefile b/sysutils/gstopd/Makefile
new file mode 100644
index 000000000000..ea1d7012e15d
--- /dev/null
+++ b/sysutils/gstopd/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gstopd
+# Date created: 18 Oct 2003
+# Whom: Michael Reifenberger
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstopd
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= mr
+
+MAINTAINER= mr@freebsd.org
+COMMENT= GEOM stop daemon
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= Needs GEOM(4)
+.endif
+
+MAN8= gstopd.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gstopd ${LOCALBASE}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/gstopd.8 ${LOCALBASE}/man/man8
+
+.include <bsd.port.post.mk>