aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gtk-imonc/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-03 00:36:01 +0800
committerpawel <pawel@FreeBSD.org>2012-11-03 00:36:01 +0800
commit9350f8502198565720cb419d49913a2f83136439 (patch)
treec552d9af121244ddc83b641a4db18fadc8a281e1 /sysutils/gtk-imonc/Makefile
parentc70f50e47ce6c0106ffe71c968420e9b48c0bcd7 (diff)
downloadfreebsd-ports-gnome-9350f8502198565720cb419d49913a2f83136439.tar.gz
freebsd-ports-gnome-9350f8502198565720cb419d49913a2f83136439.tar.zst
freebsd-ports-gnome-9350f8502198565720cb419d49913a2f83136439.zip
- Remove DEPRECATED
- Update MASTER_SITES and WWW: line - Add LICENSE - Fix desktop file PR: ports/172251 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Diffstat (limited to 'sysutils/gtk-imonc/Makefile')
-rw-r--r--sysutils/gtk-imonc/Makefile35
1 files changed, 27 insertions, 8 deletions
diff --git a/sysutils/gtk-imonc/Makefile b/sysutils/gtk-imonc/Makefile
index 93fb5d1507a9..25b1d20be9af 100644
--- a/sysutils/gtk-imonc/Makefile
+++ b/sysutils/gtk-imonc/Makefile
@@ -3,23 +3,42 @@
PORTNAME= gtk-imonc
PORTVERSION= 0.6.4.1
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= sysutils
-MASTER_SITES= http://userpage.fu-berlin.de/~zeank/gtk-imonc/download/
+MASTER_SITES= http://stefan-strigler.de/download/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A GTK2-based imond-client to control an on(e) disc fli4l router
+COMMENT= GTK2-based imond-client to control an on(e) disc fli4l router
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-11-26
+LICENSE= GPLv2 # (or later)
+
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ cairo:${PORTSDIR}/graphics/cairo \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_PKGCONFIG= build
+USE_GNOME= gdkpixbuf2 gtk20
+USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext \
+ xfixes xi xinerama xrandr xrender
+MAKE_JOBS_SAFE= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GNOME= gtk20 gnomehier
post-patch:
- @${REINPLACE_CMD} -e 's|<endian.h>|<sys/endian.h>|' \
- ${WRKSRC}/src/md5.h
+ @${REINPLACE_CMD} -e \
+ 's|/gnome/apps/Internet|/applications|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|/usr/share/pixmaps/||' ${WRKSRC}/gtk-imonc.desktop
+ @${REINPLACE_CMD} -e \
+ 's|<endian.h>|<sys/endian.h>|' ${WRKSRC}/src/md5.h
.include <bsd.port.mk>