aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gtoaster/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-08 13:49:41 +0800
committeredwin <edwin@FreeBSD.org>2003-09-08 13:49:41 +0800
commit51a472c9cedeb13c6335b133da1f5efe10c66f39 (patch)
treed59046275c92a7d38c046414ce2b9a24a029a50c /sysutils/gtoaster/Makefile
parent1b91afea40b7b290fde49c6f982cc4203526b9bd (diff)
downloadfreebsd-ports-gnome-51a472c9cedeb13c6335b133da1f5efe10c66f39.tar.gz
freebsd-ports-gnome-51a472c9cedeb13c6335b133da1f5efe10c66f39.tar.zst
freebsd-ports-gnome-51a472c9cedeb13c6335b133da1f5efe10c66f39.zip
Update port: sysutils/gtoaster
- Fix handling PORTVERSION - Reaarange USE_GNOME - machine/soundcard.h -> sys/soundcard.h PR: ports/56530 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'sysutils/gtoaster/Makefile')
-rw-r--r--sysutils/gtoaster/Makefile55
1 files changed, 40 insertions, 15 deletions
diff --git a/sysutils/gtoaster/Makefile b/sysutils/gtoaster/Makefile
index 28d8edcc1b74..31d45b82d257 100644
--- a/sysutils/gtoaster/Makefile
+++ b/sysutils/gtoaster/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= gtoaster
-PORTVERSION= 1.0.Beta6
-PORTEPOCH= 1
+PORTVERSION= 1.0.b6
+PORTEPOCH= 2
CATEGORIES= sysutils gnome
MASTER_SITES= http://gnometoaster.rulez.org/archive/
-DISTNAME= ${PORTNAME}1.0Beta6
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.b/Beta/}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@@ -19,17 +19,42 @@ COMMENT= Graphical cd cooking interface
RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools \
mkisofs:${PORTSDIR}/sysutils/mkisofs
-WRKSRC= ${WRKDIR}/gtoaster
+WRKSRC= ${WRKDIR}/${PORTNAME}
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${X11BASE}
-CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config
-
-USE_GNOME= gtk12
-USE_GMAKE= yes
USE_X_PREFIX= yes
-
-pre-configure:
- @${RM} ${WRKSRC}/config.guess
-
-.include <bsd.port.mk>
+WANT_GNOME= yes
+USE_GNOME= gnomehack gnometarget gtk12
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgnomelibs}!=""
+PKGNAMESUFFIX= -gnome
+USE_GNOME+= gnomelibs
+.else
+CONFIGURE_ARGS+= --without-gnome
+.endif
+
+.if ${HAVE_GNOME:Morbit}!=""
+USE_GNOME+= orbit
+.else
+CONFIGURE_ARGS+= --without-orbit
+.endif
+
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME+= esound
+.else
+CONFIGURE_ARGS+= --without-esd
+.endif
+
+post-extract:
+ @${RM} -f ${WRKSRC}/config.guess
+ @${TOUCH} ${WRKSRC}/config.guess
+
+post-patch:
+ ${REINPLACE_CMD} -e 's, -pthread, ${PTHREAD_LIBS},g' \
+ ${WRKSRC}/configure
+.include <bsd.port.post.mk>