aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/healthd/Makefile
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2004-08-08 20:43:40 +0800
committerjeh <jeh@FreeBSD.org>2004-08-08 20:43:40 +0800
commit95249075011520ffa48dca1da416aac577bbbe8d (patch)
tree342d445e60624a63a9960a88b41ec8db7edc070b /sysutils/healthd/Makefile
parent9b343b5d79a7ab209c6d1ee508a2f516213a003b (diff)
downloadfreebsd-ports-gnome-95249075011520ffa48dca1da416aac577bbbe8d.tar.gz
freebsd-ports-gnome-95249075011520ffa48dca1da416aac577bbbe8d.tar.zst
freebsd-ports-gnome-95249075011520ffa48dca1da416aac577bbbe8d.zip
* Fix rc.subr use so the it works properly with both 4.x and 5.x
* Fix a potential buffer overflow while reading the config file. But, since the config file is owned by root this is the least of your worries. * Enlarge the size of the _warn and _fail command strings - Overflow noticed by Pete <shipley@dis.org>
Diffstat (limited to 'sysutils/healthd/Makefile')
-rw-r--r--sysutils/healthd/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/sysutils/healthd/Makefile b/sysutils/healthd/Makefile
index 86df6cd0510c..9d386f1dec56 100644
--- a/sysutils/healthd/Makefile
+++ b/sysutils/healthd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= healthd
-PORTVERSION= 0.7.7
+PORTVERSION= 0.7.8
CATEGORIES= sysutils ipv6
MASTER_SITES= http://healthd.thehousleys.net/ \
http://healthd1.thehousleys.net/
@@ -16,6 +16,7 @@ COMMENT= A daemon to monitor vital motherboard parameters
ONLY_FOR_ARCHS= i386
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
#
@@ -35,14 +36,10 @@ HDDOCDIR= ${PREFIX}/share/doc/healthd
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if ${OSVERSION} >= 500038
-RC_SUBR?= /etc/rc.subr
-EXTRA_PATCHES= files/healthd.sh-500038
-.else
USE_RC_SUBR= yes
-.endif
post-install:
+ @${REINPLACE_CMD} -e 's|/usr/local/etc/rc.subr|${RC_SUBR}|' ${WRKSRC}/healthd.sh
${INSTALL_SCRIPT} -m 751 ${WRKSRC}/healthd.sh ${PREFIX}/etc/rc.d/healthd.sh
@if [ ! -f ${PREFIX}/etc/healthd.conf ]; then \
${ECHO} "Installing ${PREFIX}/etc/healthd.conf configuration file."; \