aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/heartbeat2
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-11-13 20:33:03 +0800
committermiwi <miwi@FreeBSD.org>2006-11-13 20:33:03 +0800
commit5026431b9af5f8fdc93aa3752ef6f046b4758cf3 (patch)
tree2b8aeb8590dfc3a8b87826c38d12a0cb951380a1 /sysutils/heartbeat2
parent9cd3767ca35868ffb55832fc4d941050c7ee6e89 (diff)
downloadfreebsd-ports-gnome-5026431b9af5f8fdc93aa3752ef6f046b4758cf3.tar.gz
freebsd-ports-gnome-5026431b9af5f8fdc93aa3752ef6f046b4758cf3.tar.zst
freebsd-ports-gnome-5026431b9af5f8fdc93aa3752ef6f046b4758cf3.zip
- Fix permissions/ownership
PR: ports/105144 Submitted by: Ulrich Spoerlein <uspoerlein@gmail.com> Approved by: maintainer
Diffstat (limited to 'sysutils/heartbeat2')
-rw-r--r--sysutils/heartbeat2/Makefile5
-rw-r--r--sysutils/heartbeat2/files/patch-ldirectord-init.d-ldirectord11
-rw-r--r--sysutils/heartbeat2/files/pkg-install.in10
3 files changed, 23 insertions, 3 deletions
diff --git a/sysutils/heartbeat2/Makefile b/sysutils/heartbeat2/Makefile
index be93b8c7c087..f8628fcc7bdb 100644
--- a/sysutils/heartbeat2/Makefile
+++ b/sysutils/heartbeat2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= heartbeat
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://linux-ha.org/download/
@@ -72,8 +73,8 @@ BATCH=no
post-deinstall:
@BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} DEINSTALL
-post-install:
- @BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+pre-install:
+ @BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
# some subdirs treat man as documentation, therefor we have to install
# those man pages manually if NOPORTDOCS is defined
diff --git a/sysutils/heartbeat2/files/patch-ldirectord-init.d-ldirectord b/sysutils/heartbeat2/files/patch-ldirectord-init.d-ldirectord
new file mode 100644
index 000000000000..fa699c652b52
--- /dev/null
+++ b/sysutils/heartbeat2/files/patch-ldirectord-init.d-ldirectord
@@ -0,0 +1,11 @@
+--- ldirectord/init.d/ldirectord.orig
++++ ldirectord/init.d/ldirectord
+@@ -22,7 +22,7 @@
+ then
+ . /etc/rc.d/init.d/functions
+ else
+- function action {
++ action() {
+ echo -n "$1... "
+ shift
+ $@
diff --git a/sysutils/heartbeat2/files/pkg-install.in b/sysutils/heartbeat2/files/pkg-install.in
index add49ae3f155..a125513bfc8e 100644
--- a/sysutils/heartbeat2/files/pkg-install.in
+++ b/sysutils/heartbeat2/files/pkg-install.in
@@ -85,7 +85,7 @@ delete_account() {
case $2 in
-POST-INSTALL)
+PRE-INSTALL)
echo ""
user=hacluster
group=haclient
@@ -96,6 +96,14 @@ POST-INSTALL)
echo "Adding empty dirs and pid file."
test -d /var/lib/heartbeat/ckpt || \
install -d -m 755 /var/lib/heartbeat/ckpt
+ test -d /var/lib/heartbeat/ccm || \
+ install -d -m 750 -o ${user} -g ${group} /var/lib/heartbeat/ccm
+ test -d /var/lib/heartbeat/cores/root || \
+ install -d -m 700 /var/lib/heartbeat/cores/root
+ test -d /var/lib/heartbeat/cores/nobody || \
+ install -d -m 700 -o nobody /var/lib/heartbeat/cores/nobody
+ test -d /var/lib/heartbeat/cores/hacluster || \
+ install -d -m 700 -o ${user} /var/lib/heartbeat/cores/hacluster
test -d /var/lock/subsys || \
install -d -m 755 /var/lock/subsys
test -f /var/run/heartbeat.pid || \