aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hextools
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2010-11-01 22:11:20 +0800
committerohauer <ohauer@FreeBSD.org>2010-11-01 22:11:20 +0800
commit408eead1ddf44887fa39b933d4cb1c7969eb87c6 (patch)
treec85ae2942899937c9a3476050d19d03a05bd5ac6 /sysutils/hextools
parente7ca5449e56da55e6f34b410abe8aa6481395354 (diff)
downloadfreebsd-ports-gnome-408eead1ddf44887fa39b933d4cb1c7969eb87c6.tar.gz
freebsd-ports-gnome-408eead1ddf44887fa39b933d4cb1c7969eb87c6.tar.zst
freebsd-ports-gnome-408eead1ddf44887fa39b933d4cb1c7969eb87c6.zip
PR: 151607
Submitted by: Eitan Adler <lists _at_ eitanadler.com> Approved by: glarkin (mentor, implicit) reversible hexdump is a hexdump/hex2bin-toolkit that dumps to a special readable and reversible hexadecimal byte-dump,where you can not only change bytes, but also insert or delete bytes. It has a flush-switch, where it will output hexbytes for each single char it reads. This is especially useful for watching output from slow devices (e.g., serial devices like mice). The hex2bin-utility (the reverse-hexdump) not only accepts hexbytes for input, but also double-quoted strings with most of the escape-chars known from C and makes good attempts at undumping even hexdumps with repetition-lines (a "*" on its own line). It's written in ANSI C. WWW: http://gnuwin32.sourceforge.net/packages/hextools.htm
Diffstat (limited to 'sysutils/hextools')
-rw-r--r--sysutils/hextools/Makefile33
-rw-r--r--sysutils/hextools/distinfo2
-rw-r--r--sysutils/hextools/pkg-descr11
3 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/hextools/Makefile b/sysutils/hextools/Makefile
new file mode 100644
index 000000000000..dee17a3fa011
--- /dev/null
+++ b/sysutils/hextools/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hextools
+# Date created: 19 Oct 2010
+# Whom: Eitan Adler
+#
+# $FreeBSD$
+#
+
+PORTNAME= hextools
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= http://avl.enemy.org/utils/hextools/
+
+MAINTAINER= ports@eitanadler.com
+COMMENT= Useful tools for dealing with hex files
+
+NO_WRKSUBDIR=yes
+
+MAN1= bin2hex.1 hex2bin.1
+PLIST_FILES= bin/hex2bin bin/bin2hex
+ALL_TARGET= build
+
+#not strictly true - it uses a self-styled license
+#LICENSE= BSD
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hex2bin ${PREFIX}/bin/hex2bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/hexdump ${PREFIX}/bin/bin2hex
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/hex2bin.1 ${MANPREFIX}/man/man1/hex2bin.1
+ ${INSTALL_MAN} ${WRKSRC}/hexdump.1 ${MANPREFIX}/man/man1/bin2hex.1
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/hextools/distinfo b/sysutils/hextools/distinfo
new file mode 100644
index 000000000000..3fc03bbc2e53
--- /dev/null
+++ b/sysutils/hextools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hextools-1.1.tar.gz) = f85c64dd2aedb1e924bc9ea11c90eaf8ea4eeef8167b00a7c34be22b3c21318b
+SIZE (hextools-1.1.tar.gz) = 7640
diff --git a/sysutils/hextools/pkg-descr b/sysutils/hextools/pkg-descr
new file mode 100644
index 000000000000..0a11d5754527
--- /dev/null
+++ b/sysutils/hextools/pkg-descr
@@ -0,0 +1,11 @@
+reversible hexdump is a hexdump/hex2bin-toolkit that dumps to a special
+readable and reversible hexadecimal byte-dump,where you can not only change
+bytes, but also insert or delete bytes. It has a flush-switch, where it will
+output hexbytes for each single char it reads. This is especially useful for
+watching output from slow devices (e.g., serial devices like mice). The
+hex2bin-utility (the reverse-hexdump) not only accepts hexbytes for input,
+but also double-quoted strings with most of the escape-chars known
+from C and makes good attempts at undumping even hexdumps with repetition-lines
+(a "*" on its own line). It's written in ANSI C.
+
+WWW: http://gnuwin32.sourceforge.net/packages/hextools.htm