aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ipsc/Makefile
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>1999-11-03 08:58:26 +0800
committerjim <jim@FreeBSD.org>1999-11-03 08:58:26 +0800
commit372894dde158fd5601c37ccd07b02a102d881561 (patch)
treef383b6d4120e5f63ab02eefb59af7d99ff6b8d73 /sysutils/ipsc/Makefile
parent4530f0f77b2c2175cf5040885a765f11f2b06037 (diff)
downloadfreebsd-ports-gnome-372894dde158fd5601c37ccd07b02a102d881561.tar.gz
freebsd-ports-gnome-372894dde158fd5601c37ccd07b02a102d881561.tar.zst
freebsd-ports-gnome-372894dde158fd5601c37ccd07b02a102d881561.zip
Import of ipsc.
IPSC is short for IP Subnet Calculator. It is a tool that allows network administrators to make calculations that will assist in subnetting a network. It also has a number of other useful functions. PR: 14638 Submitted by: Jeremy Shaffner <jeremy@external.org>
Diffstat (limited to 'sysutils/ipsc/Makefile')
-rw-r--r--sysutils/ipsc/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/ipsc/Makefile b/sysutils/ipsc/Makefile
new file mode 100644
index 000000000000..14146f8f1958
--- /dev/null
+++ b/sysutils/ipsc/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ipsc
+# Version required: 0.3.2
+# Date created: 31 October 1999
+# Whom: Jeremy Shaffner <jeremy@external.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= ipsc-0.3.2-src
+PKGNAME= ipsc-0.3.2
+CATEGORIES= sysutils x11
+MASTER_SITES= http://www.interloper.net/~dan/software/dist/ipsc/
+
+MAINTAINER= jeremy@external.org
+
+BUILD_DEPENDS= ${WRKDIRPREFIX}${PORTSDIR}/sysutils/prips/work/prips.o:${PORTSDIR}/sysutils/prips:build
+.if defined(USE_GTK)
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+.endif
+
+WRKSRC= ${WRKDIR}/ipsc
+
+.if defined(USE_GTK)
+PLIST= ${PKGDIR}/PLIST.gtk
+ALL_TARGET= all
+.else
+ALL_TARGET= ipsc
+.endif
+
+pre-build:
+ @${LN} -s ${WRKDIRPREFIX}${PORTSDIR}/sysutils/prips/work/prips \
+ ${WRKDIR}/prips
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/ipsc ${PREFIX}/bin
+.if defined(USE_GTK)
+ @${INSTALL_PROGRAM} ${WRKSRC}/gipsc ${PREFIX}/bin
+.endif
+
+.include <bsd.port.mk>