aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ipsc/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>2000-01-12 13:57:54 +0800
committercpiazza <cpiazza@FreeBSD.org>2000-01-12 13:57:54 +0800
commitc0036fd73b447343d2e6bd6709919a51a16db1ec (patch)
tree59c4e3f3cd3250689ea8567a8e5432e55e920c02 /sysutils/ipsc/Makefile
parent950adbaf82236e0158af8fea8ddcda745f1f7654 (diff)
downloadfreebsd-ports-gnome-c0036fd73b447343d2e6bd6709919a51a16db1ec.tar.gz
freebsd-ports-gnome-c0036fd73b447343d2e6bd6709919a51a16db1ec.tar.zst
freebsd-ports-gnome-c0036fd73b447343d2e6bd6709919a51a16db1ec.zip
Update to 0.4.2
PR: 16054 Submitted by: maintainer
Diffstat (limited to 'sysutils/ipsc/Makefile')
-rw-r--r--sysutils/ipsc/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/sysutils/ipsc/Makefile b/sysutils/ipsc/Makefile
index 38aed796b7e8..5673b51f4729 100644
--- a/sysutils/ipsc/Makefile
+++ b/sysutils/ipsc/Makefile
@@ -1,26 +1,31 @@
# New ports collection makefile for: ipsc
-# Version required: 0.4.0
+# Version required: 0.4.2
# Date created: 31 October 1999
# Whom: Jeremy Shaffner <jeremy@external.org>
#
# $FreeBSD$
#
-DISTNAME= ipsc-0.4.0-src
-PKGNAME= ipsc-0.4.0
+DISTNAME= ipsc-0.4.2-src
+PKGNAME= ipsc-0.4.2
CATEGORIES= sysutils gnome x11
MASTER_SITES= http://www.interloper.net/~dan/software/dist/ipsc/
MAINTAINER= jeremy@external.org
-BUILD_DEPENDS= ${WRKDIRPREFIX}${PORTSDIR}/sysutils/prips/work/prips.o:${PORTSDIR}/sysutils/prips:build
+BUILD_DEPENDS= ${WRKDIRPREFIX}${PORTSDIR}/sysutils/prips/work/prips/prips.o:${PORTSDIR}/sysutils/prips:build
.if defined(USE_GNOME)
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
-WRKSRC= ${WRKDIR}/ipsc
+WRKSRC= ${WRKDIR}/ipsc/src
+post-extract:
+ @${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../prips/work/prips \
+ ${WRKDIR}/prips
+
+pre-build:
.if defined(USE_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome
ALL_TARGET= all
@@ -28,9 +33,12 @@ ALL_TARGET= all
ALL_TARGET= ipsc
.endif
-pre-build:
- @${LN} -s ${WRKDIRPREFIX}${PORTSDIR}/sysutils/prips/work/prips \
- ${WRKDIR}/prips
+post-build:
+.if defined(USE_GNOME)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Don't forget to define USE_GNOME when installing"
+ @${ECHO_MSG} ""
+.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/ipsc ${PREFIX}/bin