aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/lavaps
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-11-25 06:13:33 +0800
committerstas <stas@FreeBSD.org>2006-11-25 06:13:33 +0800
commit2845732437b1c7d41295944b45d9083c52b8bee5 (patch)
treeb493aa6f782aa6533009acfde9fe1b978fe4153a /sysutils/lavaps
parent468f3c659a29ad688e306b09e84df08385739eee (diff)
downloadfreebsd-ports-gnome-2845732437b1c7d41295944b45d9083c52b8bee5.tar.gz
freebsd-ports-gnome-2845732437b1c7d41295944b45d9083c52b8bee5.tar.zst
freebsd-ports-gnome-2845732437b1c7d41295944b45d9083c52b8bee5.zip
- Allow to select frontend type via options
- Respect X11BASE Reported by: kris
Diffstat (limited to 'sysutils/lavaps')
-rw-r--r--sysutils/lavaps/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/sysutils/lavaps/Makefile b/sysutils/lavaps/Makefile
index f6d474105e21..60f3f167d0d3 100644
--- a/sysutils/lavaps/Makefile
+++ b/sysutils/lavaps/Makefile
@@ -11,27 +11,32 @@ PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.isi.edu/~johnh/SOFTWARE/LAVAPS/
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= A lava lamp of currently running processes
-WANT_GNOME= yes
+GNU_CONFIGURE= yes
USE_GNOME= gnometarget
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= -x-includes="${X11BASE}/include" -x-libraries="${X11BASE}/lib"
USE_PERL5_BUILD= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= lavaps.1
TCL_VER?= 8.4
-CPPFLAGS= -I${LOCALBASE}/include/tcl${TCL_VER} \
+CPPFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} \
-I${LOCALBASE}/include/tk${TCL_VER} \
-I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} \
+ -I${LOCALBASE}/include/tk${TCL_VER} \
+ -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS= GTK "Build with GTK frontend instead of the default TK" off
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgtk20}!=""
+.if defined(WITH_GTK)
PKGNAMESUFFIX= -gtk2
USE_GNOME+= gtk20
USE_GETTEXT= yes