aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ldapvi
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-27 02:53:12 +0800
committerpav <pav@FreeBSD.org>2006-04-27 02:53:12 +0800
commit96dd82771d7b5ed0f9f11d4943d7e3569a208dcc (patch)
tree6b7fec0f4f49f47ef0cd2737596b56cf6c7f80a4 /sysutils/ldapvi
parent1d387ed06fa30618ccf4c33566cd384d66a6631e (diff)
downloadfreebsd-ports-gnome-96dd82771d7b5ed0f9f11d4943d7e3569a208dcc.tar.gz
freebsd-ports-gnome-96dd82771d7b5ed0f9f11d4943d7e3569a208dcc.tar.zst
freebsd-ports-gnome-96dd82771d7b5ed0f9f11d4943d7e3569a208dcc.zip
ldapvi is tool to update LDAP entries with a text editor.
It is: # Written in C. # Reasonably fast and small. The ldapvi client needs about as much time for receiving entries as the OpenLDAP server needs to sends them, which should be fast enough. # Shows a summary of changes before committing them. Details of the changes can be previewed in LDIF format. # Uses an LDIF-like format in the editor (which should be easier to use interactively than standard LDIF). # Can rename entries. # Does not give up easily. On error, you can edit the file again or rebind to the server and try again. WWW: http://www.lichteblau.com/ldapvi.html PR: ports/96255 Submitted by: Joerg Pulz <Joerg.Pulz@frm2.tum.de>
Diffstat (limited to 'sysutils/ldapvi')
-rw-r--r--sysutils/ldapvi/Makefile45
-rw-r--r--sysutils/ldapvi/distinfo6
-rw-r--r--sysutils/ldapvi/pkg-descr16
3 files changed, 67 insertions, 0 deletions
diff --git a/sysutils/ldapvi/Makefile b/sysutils/ldapvi/Makefile
new file mode 100644
index 000000000000..3328079b5321
--- /dev/null
+++ b/sysutils/ldapvi/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: ldapvi
+# Date created: Mon Apr 24 09:37:02 CEST 2006
+# Whom: Joerg Pulz <Joerg.Pulz@frm2.tum.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldapvi
+PORTVERSION= 1.5
+CATEGORIES= sysutils net
+MASTER_SITES= http://www.lichteblau.com/download/
+
+MAINTAINER= Joerg.Pulz@frm2.tum.de
+COMMENT= A tool to update LDAP entries with a text editor
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+USE_OPENLDAP= yes
+USE_GNOME= pkgconfig glib20
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+MAN1= ldapvi.1
+PLIST_FILES= bin/ldapvi
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WANT_OPENLDAP_SASL) && !defined(WITHOUT_SASL)
+PATCH_SITES= http://w3.gofti.com/~pfnguyen/openldap/
+PATCHFILES= ldapvi_sasl_${PORTVERSION}.diff
+PATCH_DIST_STRIP= -p1
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/ldapvi/distinfo b/sysutils/ldapvi/distinfo
new file mode 100644
index 000000000000..792ad57fb485
--- /dev/null
+++ b/sysutils/ldapvi/distinfo
@@ -0,0 +1,6 @@
+MD5 (ldapvi-1.5.tar.gz) = e98f9fbd5596aac81373a849888a87f1
+SHA256 (ldapvi-1.5.tar.gz) = 2515249e3e9e36dd78e319b08b8e812c0f186a691a598489119faa8b828b6330
+SIZE (ldapvi-1.5.tar.gz) = 75707
+MD5 (ldapvi_sasl_1.5.diff) = 82dcae24b138bef5c6ef344533c7490f
+SHA256 (ldapvi_sasl_1.5.diff) = 9bd02c5073a4238c6431967716dbb74cfae7157dba240f106ac2e2df97b5739e
+SIZE (ldapvi_sasl_1.5.diff) = 69412
diff --git a/sysutils/ldapvi/pkg-descr b/sysutils/ldapvi/pkg-descr
new file mode 100644
index 000000000000..d63e819a1369
--- /dev/null
+++ b/sysutils/ldapvi/pkg-descr
@@ -0,0 +1,16 @@
+ldapvi is tool to update LDAP entries with a text editor.
+
+It is:
+# Written in C.
+# Reasonably fast and small. The ldapvi client needs about as much time for
+ receiving entries as the OpenLDAP server needs to sends them, which should be
+ fast enough.
+# Shows a summary of changes before committing them. Details of the changes can
+ be previewed in LDIF format.
+# Uses an LDIF-like format in the editor (which should be easier to use
+ interactively than standard LDIF).
+# Can rename entries.
+# Does not give up easily. On error, you can edit the file again or rebind to
+ the server and try again.
+
+WWW: http://www.lichteblau.com/ldapvi.html