aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/linux-acu
diff options
context:
space:
mode:
authorambrisko <ambrisko@FreeBSD.org>2002-06-27 10:42:14 +0800
committerambrisko <ambrisko@FreeBSD.org>2002-06-27 10:42:14 +0800
commite2dc04e044a2ee494ade3ebe46738f4362fb30f0 (patch)
treefaeda96834433ef4d5ed44421b018134bafbe7ea /sysutils/linux-acu
parenta454a240edd4c3d81ec392ffc729ff7b15e7347f (diff)
downloadfreebsd-ports-gnome-e2dc04e044a2ee494ade3ebe46738f4362fb30f0.tar.gz
freebsd-ports-gnome-e2dc04e044a2ee494ade3ebe46738f4362fb30f0.tar.zst
freebsd-ports-gnome-e2dc04e044a2ee494ade3ebe46738f4362fb30f0.zip
Aironet Cisco Utilities for 802.11 wireless NIC's. Runs under Linux
emulation. Submitted by: Matt Peterson <matt@peterson.org>
Diffstat (limited to 'sysutils/linux-acu')
-rw-r--r--sysutils/linux-acu/Makefile57
-rw-r--r--sysutils/linux-acu/distinfo1
-rw-r--r--sysutils/linux-acu/pkg-comment1
-rw-r--r--sysutils/linux-acu/pkg-descr12
-rw-r--r--sysutils/linux-acu/pkg-message8
-rw-r--r--sysutils/linux-acu/pkg-plist3
6 files changed, 82 insertions, 0 deletions
diff --git a/sysutils/linux-acu/Makefile b/sysutils/linux-acu/Makefile
new file mode 100644
index 000000000000..55210b28c7c2
--- /dev/null
+++ b/sysutils/linux-acu/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: linux-acu
+# Date created: Tue Jun 25 02:24:41 GMT 2002
+# Whom: Matt Peterson <matt@peterson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= acu
+PORTVERSION= 2.0
+CATEGORIES= sysutils
+MASTER_SITES= # fetch manually
+PKGNAMEPREFIX= linux-
+DISTNAME= Linux-ACU-Driver-v${PORTVERSION}
+
+MAINTAINER= matt@peterson.org
+
+RUN_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
+ ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+
+.include <bsd.port.pre.mk>
+
+#.if ${OSVERSION} < 460000
+#BROKEN= "${PORTNAME} is not available for your version of FreeBSD. Please upgrade."
+#.endif
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= may not be automatically fetched due to licensing\
+ restrictions. You MUST manually fetch the tarball after\
+ reading and agreeing to the license at:\
+ http://www.cisco.com/pcgi-bin/tablebuild.pl/aironet-utils-linux\
+ - once '${DISTNAME}${EXTRACT_SUFX}' has been downloaded, move it to\
+ ${DISTDIR} and then restart this build.
+.endif
+
+ONLY_FOR_ARCHS= i386
+USE_XLIB= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_CDROM= "Redistribution not allowed"
+
+do-install:
+ @${MKDIR} ${PREFIX}/bin
+ @${MKDIR} ${LINUXBASE}/proc/aironet
+ @${INSTALL} ${WRKSRC}/utilities/acu ${PREFIX}/bin
+
+post-install:
+ @${ECHO} "acu installed under ${PREFIX}/bin"
+ @${ECHO} "notes: acu will only run from the root super-user account"
+ @${ECHO} " to allow root access to your X session,"
+ @${ECHO} " run 'xhost localhost' or use sudo."
+ @${ECHO} " acu will not run with linprocfs since it needs to see:"
+ @${ECHO} " ${LINUXBASE}/proc/aironet""
+ @${ECHO} " acu annoyingly creates"
+ @${ECHO} " /compat/linux/etc/eth2.cfg"
+ @${ECHO} " and will use that over the current card's settings."
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/linux-acu/distinfo b/sysutils/linux-acu/distinfo
new file mode 100644
index 000000000000..be5145cce51f
--- /dev/null
+++ b/sysutils/linux-acu/distinfo
@@ -0,0 +1 @@
+MD5 (Linux-ACU-Driver-v2.0.tar.gz) = 5985ebe4cf6b7b7e8535bb73031c4a6d
diff --git a/sysutils/linux-acu/pkg-comment b/sysutils/linux-acu/pkg-comment
new file mode 100644
index 000000000000..6150a9063983
--- /dev/null
+++ b/sysutils/linux-acu/pkg-comment
@@ -0,0 +1 @@
+Aironet Cisco Utilities for 802.11 wireless NIC's
diff --git a/sysutils/linux-acu/pkg-descr b/sysutils/linux-acu/pkg-descr
new file mode 100644
index 000000000000..95a9ab2985dc
--- /dev/null
+++ b/sysutils/linux-acu/pkg-descr
@@ -0,0 +1,12 @@
+ACU is the Aironet Cisco Utilities.
+
+The ACU is used to configure Cisco/Aironet 802.11 wireless cards. This
+GTK utility includes tools for link monitoring, LEAP authentication, and
+other specific functions not available with ancontrol(8).
+
+This port consists of Cisco's Linux ACU client which runs on FreeBSD using
+the linux emulation system.
+
+WWW: http://www.cisco.com/pcgi-bin/tablebuild.pl/aironet-utils-linux
+
+Matt Peterson <matt@peterson.org>
diff --git a/sysutils/linux-acu/pkg-message b/sysutils/linux-acu/pkg-message
new file mode 100644
index 000000000000..ab0229b334f7
--- /dev/null
+++ b/sysutils/linux-acu/pkg-message
@@ -0,0 +1,8 @@
+acu installed under ${PREFIX}/bin
+ to allow root access to your X session,
+ run 'xhost localhost' or use sudo.
+ acu will not run with linprocfs since it needs to see:
+ /compact/linux/proc/aironet
+ acu annoyingly creates
+ /compat/linux/etc/eth2.cfg
+ and will use that over the current card's settings.
diff --git a/sysutils/linux-acu/pkg-plist b/sysutils/linux-acu/pkg-plist
new file mode 100644
index 000000000000..a69cc080de38
--- /dev/null
+++ b/sysutils/linux-acu/pkg-plist
@@ -0,0 +1,3 @@
+bin/acu
+@exec mkdir -p /compat/linux/proc/aironet
+@unexec rm -rf /compat/linux/proc/aironet