aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/logtool/Makefile
diff options
context:
space:
mode:
authorkeith <keith@FreeBSD.org>2001-01-13 02:47:04 +0800
committerkeith <keith@FreeBSD.org>2001-01-13 02:47:04 +0800
commit95a3372830c4c3695eda9e7d3e990f5d4dfac99e (patch)
treefd6c5d0f7d1c6d6f280d4de94233e17992f25f02 /sysutils/logtool/Makefile
parentf12f20c1727e44a72b1229dc921c5e3e1da683e1 (diff)
downloadfreebsd-ports-gnome-95a3372830c4c3695eda9e7d3e990f5d4dfac99e.tar.gz
freebsd-ports-gnome-95a3372830c4c3695eda9e7d3e990f5d4dfac99e.tar.zst
freebsd-ports-gnome-95a3372830c4c3695eda9e7d3e990f5d4dfac99e.zip
Update to 1.0.2 and install documents.
PR: ports/24205 Submitted by: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw> (MAINTAINER)
Diffstat (limited to 'sysutils/logtool/Makefile')
-rw-r--r--sysutils/logtool/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/sysutils/logtool/Makefile b/sysutils/logtool/Makefile
index fa42950c7861..f5eda995ac39 100644
--- a/sysutils/logtool/Makefile
+++ b/sysutils/logtool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= logtool
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= sysutils
MASTER_SITES= http://users.digitex.net/~max/
@@ -17,6 +17,12 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_GMAKE= yes
ALL_TARGET= build
+.if defined(NOPORTDOCS)
+NODOCS= "@comment "
+.endif
+
+PLIST_SUB= NOPORTDOCS=${NODOCS}
+
post-patch:
@${PERL} -pi -e "s|make|${GMAKE}|g" ${WRKSRC}/Makefile
.for file in logtool/Makefile logtail/Makefile
@@ -24,4 +30,11 @@ post-patch:
.endfor
@${PERL} -pi -e "s|/etc|${PREFIX}/etc|g" ${WRKSRC}/logtool/config.h
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing logtool docs in ${PREFIX}/share/doc/logtool"
+ @${MKDIR} ${PREFIX}/share/doc/logtool && ${CHMOD} a+rx ${PREFIX}/share/doc/logtool
+ @${CP} -r ${WRKSRC}/doc/* ${PREFIX}/share/doc/logtool
+.endif
+
.include <bsd.port.mk>