aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/logtool/files
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2000-12-31 00:46:49 +0800
committeralex <alex@FreeBSD.org>2000-12-31 00:46:49 +0800
commit45b8e478c1143aac785a3b7d284d1c3f0463108b (patch)
tree10414907c1ec176fb0dd804cf2f400bce23c5421 /sysutils/logtool/files
parent732003ce0be26c16a66620f45be292ee14061ef2 (diff)
downloadfreebsd-ports-gnome-45b8e478c1143aac785a3b7d284d1c3f0463108b.tar.gz
freebsd-ports-gnome-45b8e478c1143aac785a3b7d284d1c3f0463108b.tar.zst
freebsd-ports-gnome-45b8e478c1143aac785a3b7d284d1c3f0463108b.zip
Add logtool 1.0.1, a command line program, that will parse syslog and
syslog-alike logfiles into a more palatable format. PR: 23956 Submitted by: Ying-Chieh Liao <ijliao@terry.dragon2.net>
Diffstat (limited to 'sysutils/logtool/files')
-rw-r--r--sysutils/logtool/files/patch-aa37
-rw-r--r--sysutils/logtool/files/patch-ab10
-rw-r--r--sysutils/logtool/files/patch-ac11
-rw-r--r--sysutils/logtool/files/patch-ad11
4 files changed, 69 insertions, 0 deletions
diff --git a/sysutils/logtool/files/patch-aa b/sysutils/logtool/files/patch-aa
new file mode 100644
index 000000000000..6f3f655400b7
--- /dev/null
+++ b/sysutils/logtool/files/patch-aa
@@ -0,0 +1,37 @@
+--- logtool/Makefile.orig Sat Dec 30 16:57:27 2000
++++ logtool/Makefile Sat Dec 30 20:43:49 2000
+@@ -9,12 +9,13 @@
+ csv.o html.o raw.o logtool.o main.o
+ SRC = logtool.c
+ # These options affect where logtool gets installed
+-PREFIX = /usr
+-ETCDIR = /etc/logtool
++PREFIX = %%PREFIX%%
++ETCDIR = %%PREFIX%%/etc/logtool
+ CC = gcc
+
+ # For RedHat (and most other) Linux'es, this should be ideal
+-CFLAGS= -Wall -O3 -ansi -pedantic -Werror # -DDEBUG -g # uncomment this for debugging stuff's
++CFLAGS= -I/usr/local/include -Wall -O3 -ansi -pedantic -Werror # -DDEBUG -g # uncomment this for debugging stuff's
++LIBS= -L/usr/local/lib -lgnugetopt
+
+ # For portability to non-linux'es/non-standard-linux'es, try this
+ # CFLAGS = -Wall -Werror
+@@ -22,7 +23,7 @@
+
+ ### The main build stuff
+ logtool: logtool.o $(LIB)
+- $(CC) -o $(PROG) logtool.o $(LIB) $(ADDCFLAGS)
++ $(CC) -o $(PROG) logtool.o $(LIB) $(ADDCFLAGS) ${LIBS}
+ @echo "strip $(PROG)"
+ @strip $(PROG)
+
+@@ -56,7 +57,7 @@
+
+ ### How to install this puppy
+ install: logtool
+- mkdir -p /etc/logtool
++ mkdir -p ${ETCDIR}
+ install -c -m 0644 -o root ../conf/logtool.conf $(ETCDIR)/logtool.conf
+ install -c -m 0644 -o root ../conf/green $(ETCDIR)/green
+ install -c -m 0644 -o root ../conf/yellow $(ETCDIR)/yellow
diff --git a/sysutils/logtool/files/patch-ab b/sysutils/logtool/files/patch-ab
new file mode 100644
index 000000000000..d157f7fb0176
--- /dev/null
+++ b/sysutils/logtool/files/patch-ab
@@ -0,0 +1,10 @@
+--- logtool/includes.h.orig Sat Dec 30 20:19:32 2000
++++ logtool/includes.h Sat Dec 30 20:40:09 2000
+@@ -23,6 +23,7 @@
+ #include<stdlib.h>
+ #include<string.h>
+ #include<getopt.h>
++#include<unistd.h>
+ #include<regex.h>
+ #include<errno.h>
+
diff --git a/sysutils/logtool/files/patch-ac b/sysutils/logtool/files/patch-ac
new file mode 100644
index 000000000000..e4a1e31c8f8a
--- /dev/null
+++ b/sysutils/logtool/files/patch-ac
@@ -0,0 +1,11 @@
+--- logtool/logtool.h.orig Sat Dec 30 20:21:40 2000
++++ logtool/logtool.h Sat Dec 30 20:22:16 2000
+@@ -62,7 +62,7 @@
+ * For some reason string.h doesn't define this, so I do it here
+ * Are there portability problems with strncasesmp or sumpthin?
+ */
+-int strncasecmp(char *s1, char *s2, size_t size);
++/*int strncasecmp(char *s1, char *s2, size_t size); */
+
+
+ /*
diff --git a/sysutils/logtool/files/patch-ad b/sysutils/logtool/files/patch-ad
new file mode 100644
index 000000000000..792b3a7404bd
--- /dev/null
+++ b/sysutils/logtool/files/patch-ad
@@ -0,0 +1,11 @@
+--- logtail/Makefile.orig Sat Dec 30 20:17:09 2000
++++ logtail/Makefile Sat Dec 30 20:17:35 2000
+@@ -2,7 +2,7 @@
+ PROG= logtail
+ CC= gcc
+ CFLAGS= -Wall -Werror -O3 -ansi -pedantic
+-PREFIX=/usr
++PREFIX=%%PREFIX%%
+
+ default:
+ $(CC) $(CFLAGS) -o $(PROG) $(SRC)