aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/lsmlib/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-24 23:06:22 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-24 23:06:22 +0800
commitcbb75135978aca681fc0bc5f49c33ffe118fbe3e (patch)
treebebeba770c7230cf28b682565fd2d5e6f0db800b /sysutils/lsmlib/Makefile
parent8bf2ad46f90f6f79e88927c0a3d71f9cb7bb9a24 (diff)
downloadfreebsd-ports-gnome-cbb75135978aca681fc0bc5f49c33ffe118fbe3e.tar.gz
freebsd-ports-gnome-cbb75135978aca681fc0bc5f49c33ffe118fbe3e.tar.zst
freebsd-ports-gnome-cbb75135978aca681fc0bc5f49c33ffe118fbe3e.zip
add lsmlib
A lib that creates a libxml2 tree w/ info. token on a *NIX filesystem
Diffstat (limited to 'sysutils/lsmlib/Makefile')
-rw-r--r--sysutils/lsmlib/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/lsmlib/Makefile b/sysutils/lsmlib/Makefile
new file mode 100644
index 000000000000..0f0d4ca61216
--- /dev/null
+++ b/sysutils/lsmlib/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: lsmlib
+# Date created: Jul 24, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= lsmlib
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://lsmlib.sourceforge.net/releases/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+
+XML2_CONFIG?= ${LOCALBASE}/bin/xml2-config
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+MAKEFILE= makefile
+MAKE_ENV= XML2_CONFIG="${XML2_CONFIG}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lsm ${PREFIX}/bin
+
+.include <bsd.port.mk>