aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/mate-system-monitor
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-07-28 04:19:33 +0800
committerkwm <kwm@FreeBSD.org>2015-07-28 04:19:33 +0800
commitf3a030abc46a4b0256ee69dd4918b96f535a295d (patch)
tree0d276f72ec80621ae31f35239a1c27ae16c21bba /sysutils/mate-system-monitor
parentc0e75495d2db694b13f48fd2ce73094f2affcc17 (diff)
downloadfreebsd-ports-gnome-f3a030abc46a4b0256ee69dd4918b96f535a295d.tar.gz
freebsd-ports-gnome-f3a030abc46a4b0256ee69dd4918b96f535a295d.tar.zst
freebsd-ports-gnome-f3a030abc46a4b0256ee69dd4918b96f535a295d.zip
Update MATE DE to 1.10.0.
This MATE is still build agains GTK+2. Sort USES here and there. Replace mate-dialogs with zenity and mate-calc with galculator. This update fixes the following PR's: PR: 193942, 191885 Submitted by: Gustau Perez <gustau.perez@gmail.com> via Gnome devel repo Obtained from: gnome devel repo.
Diffstat (limited to 'sysutils/mate-system-monitor')
-rw-r--r--sysutils/mate-system-monitor/Makefile6
-rw-r--r--sysutils/mate-system-monitor/distinfo4
-rw-r--r--sysutils/mate-system-monitor/files/patch-src_load-graph.cpp20
-rw-r--r--sysutils/mate-system-monitor/files/patch-src_openfiles.cpp14
-rw-r--r--sysutils/mate-system-monitor/files/patch-src_procproperties.cpp20
-rw-r--r--sysutils/mate-system-monitor/pkg-plist1
6 files changed, 36 insertions, 29 deletions
diff --git a/sysutils/mate-system-monitor/Makefile b/sysutils/mate-system-monitor/Makefile
index 8aabb2c82626..c4a953040d3d 100644
--- a/sysutils/mate-system-monitor/Makefile
+++ b/sysutils/mate-system-monitor/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mate-system-monitor
-PORTVERSION= 1.8.0
-PORTREVISION= 1
+PORTVERSION= 1.10.1
CATEGORIES= sysutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -19,7 +18,8 @@ PORTSCOUT= limitw:1,even
USES= gettext gmake pathfix pkgconfig tar:xz
USE_MATE= icontheme
-USE_GNOME= gtk20 librsvg2 intlhack libxml2 gtkmm24 libwnck
+USE_GNOME= gtk20 gtkmm24 intlhack librsvg2 libwnck libxml2
+CONFIGURE_ARGS= --with-gtk=2.0
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-lutil"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/mate-system-monitor/distinfo b/sysutils/mate-system-monitor/distinfo
index 0e532131a525..9dc30a15cf4e 100644
--- a/sysutils/mate-system-monitor/distinfo
+++ b/sysutils/mate-system-monitor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mate/mate-system-monitor-1.8.0.tar.xz) = 00ef3c595d4837e44f70c40e683a292836c9c8a84d1f9ab66f5b97a206f47712
-SIZE (mate/mate-system-monitor-1.8.0.tar.xz) = 2099600
+SHA256 (mate/mate-system-monitor-1.10.1.tar.xz) = d5428990f9ba2a864a9c4af74c626c3e8f46f0b0468925209ad51f2d09304774
+SIZE (mate/mate-system-monitor-1.10.1.tar.xz) = 2129620
diff --git a/sysutils/mate-system-monitor/files/patch-src_load-graph.cpp b/sysutils/mate-system-monitor/files/patch-src_load-graph.cpp
index 9b934be3ddb8..32f01f89c021 100644
--- a/sysutils/mate-system-monitor/files/patch-src_load-graph.cpp
+++ b/sysutils/mate-system-monitor/files/patch-src_load-graph.cpp
@@ -1,11 +1,11 @@
---- src/load-graph.cpp.orig 2008-01-14 23:43:43.000000000 -0600
-+++ src/load-graph.cpp 2008-01-14 23:44:15.000000000 -0600
-@@ -412,7 +412,7 @@
- // e.g: ceil(100.5 KiB) = 101 KiB = 101 * 2**(1 * 10)
- // where base10 = 1, coef10 = 101, pow2 = 16
+--- src/load-graph.cpp.orig 2015-01-23 09:15:58.000000000 +0100
++++ src/load-graph.cpp 2015-04-06 20:28:18.053368000 +0200
+@@ -470,7 +470,7 @@
+ // e.g: ceil(100.5 KiB) = 101 KiB = 101 * 2**(1 * 10)
+ // where base10 = 1, coef10 = 101, pow2 = 16
-- unsigned pow2 = std::floor(log2(new_max));
-+ unsigned pow2 = std::floor(log(new_max) / log(2));
- unsigned base10 = pow2 / 10;
- unsigned coef10 = std::ceil(new_max / double(1UL << (base10 * 10)));
- g_assert(new_max <= (coef10 * (1UL << (base10 * 10))));
+- guint64 pow2 = std::floor(log2(new_max));
++ guint64 pow2 = std::floor(log(new_max) / log(2));
+ guint64 base10 = pow2 / 10.0;
+ guint64 coef10 = std::ceil(new_max / double(G_GUINT64_CONSTANT(1) << (base10 * 10)));
+ g_assert(new_max <= (coef10 * (G_GUINT64_CONSTANT(1) << (base10 * 10))));
diff --git a/sysutils/mate-system-monitor/files/patch-src_openfiles.cpp b/sysutils/mate-system-monitor/files/patch-src_openfiles.cpp
deleted file mode 100644
index c00526174921..000000000000
--- a/sysutils/mate-system-monitor/files/patch-src_openfiles.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/openfiles.cpp.orig 2008-05-27 16:16:46.000000000 -0400
-+++ src/openfiles.cpp 2008-05-27 16:19:53.000000000 -0400
-@@ -66,7 +66,11 @@ friendlier_hostname(const char *addr_str
- goto failsafe;
-
- if (getnameinfo(res->ai_addr, res->ai_addrlen, hostname,
-+#ifdef NI_IDN
- sizeof hostname, service, sizeof service, NI_IDN))
-+#else
-+ sizeof hostname, service, sizeof service, 0))
-+#endif
- goto failsafe;
-
- if (res) freeaddrinfo(res);
diff --git a/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp b/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp
new file mode 100644
index 000000000000..7daeab5c60d6
--- /dev/null
+++ b/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp
@@ -0,0 +1,20 @@
+--- src/procproperties.cpp.orig 2015-07-02 23:46:27.000000000 +0200
++++ src/procproperties.cpp 2015-07-14 10:18:48.273918000 +0200
+@@ -26,7 +26,7 @@
+ #include <glibtop/procstate.h>
+ #if defined (__linux__)
+ #include <asm/param.h>
+-#elif defined (__NetBSD__) || defined (__OpenBSD__)
++#elif defined (__NetBSD__) || defined (__OpenBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
+ #include <sys/param.h>
+ #include <sys/sysctl.h>
+ #endif
+@@ -114,7 +114,7 @@
+
+ get_process_memory_info(info);
+
+-#if defined (__NetBSD__) || defined (__OpenBSD__)
++#if defined (__NetBSD__) || defined (__OpenBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
+ struct clockinfo cinf;
+ size_t size = sizeof (cinf);
+ int HZ;
diff --git a/sysutils/mate-system-monitor/pkg-plist b/sysutils/mate-system-monitor/pkg-plist
index ba553fca6439..3aa31cd9e7d4 100644
--- a/sysutils/mate-system-monitor/pkg-plist
+++ b/sysutils/mate-system-monitor/pkg-plist
@@ -1,6 +1,7 @@
bin/mate-system-monitor
man/man1/mate-system-monitor.1.gz
share/MateConf/gsettings/mate-system-monitor.convert
+share/appdata/mate-system-monitor.appdata.xml
share/applications/mate-system-monitor.desktop
share/help/C/mate-system-monitor/figures/addColumn.png
share/help/C/mate-system-monitor/figures/changePriority.png