aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/mate-system-monitor
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2016-01-25 20:31:21 +0800
committerkwm <kwm@FreeBSD.org>2016-01-25 20:31:21 +0800
commit62697e4d49308fc48297ac37f3b110750703a6d4 (patch)
tree329fd827b9752aa3d875c61d8b9e9d31a7803dd7 /sysutils/mate-system-monitor
parentf78d827a322ae8051f61800cc19a7e537d2b92b4 (diff)
downloadfreebsd-ports-gnome-62697e4d49308fc48297ac37f3b110750703a6d4.tar.gz
freebsd-ports-gnome-62697e4d49308fc48297ac37f3b110750703a6d4.tar.zst
freebsd-ports-gnome-62697e4d49308fc48297ac37f3b110750703a6d4.zip
Update the MATE DE to 1.12.
* Still build MATE against gtk+ 2 due to gtk+ 3 support not ready for prime time. * Fix loading of a number of applets. We rename a number of applets but didn't change the "config" files the "add applet to panel" dialog uses. [1] * Unbreak the creation of new notes with the stickynotes applet [2] PR: 205391 [1], 200349 [2] Obtained from: GNOME devel repo
Diffstat (limited to 'sysutils/mate-system-monitor')
-rw-r--r--sysutils/mate-system-monitor/Makefile7
-rw-r--r--sysutils/mate-system-monitor/distinfo4
-rw-r--r--sysutils/mate-system-monitor/files/patch-src_lsof.cpp14
3 files changed, 20 insertions, 5 deletions
diff --git a/sysutils/mate-system-monitor/Makefile b/sysutils/mate-system-monitor/Makefile
index eb2c9d973784..3c091daa7278 100644
--- a/sysutils/mate-system-monitor/Makefile
+++ b/sysutils/mate-system-monitor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mate-system-monitor
-PORTVERSION= 1.10.1
+PORTVERSION= 1.12.1
CATEGORIES= sysutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -16,12 +16,13 @@ LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
PORTSCOUT= limitw:1,even
-USES= alias gettext gmake pathfix pkgconfig tar:xz
+USES= alias compiler:c++11-lang gettext gmake pathfix \
+ pkgconfig tar:xz
USE_MATE= icontheme
USE_GNOME= gtk20 gtkmm24 intlhack librsvg2 libwnck libxml2
CONFIGURE_ARGS= --with-gtk=2.0
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-lutil"
+CONFIGURE_ENV= LIBS="-lutil" DATADIRNAME="share"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/sysutils/mate-system-monitor/distinfo b/sysutils/mate-system-monitor/distinfo
index 9dc30a15cf4e..6b462172d5eb 100644
--- a/sysutils/mate-system-monitor/distinfo
+++ b/sysutils/mate-system-monitor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mate/mate-system-monitor-1.10.1.tar.xz) = d5428990f9ba2a864a9c4af74c626c3e8f46f0b0468925209ad51f2d09304774
-SIZE (mate/mate-system-monitor-1.10.1.tar.xz) = 2129620
+SHA256 (mate/mate-system-monitor-1.12.1.tar.xz) = 7668ecba70b7f56f3bcfb143cb6b93a15daf8636fcf678491112afea1a49dea9
+SIZE (mate/mate-system-monitor-1.12.1.tar.xz) = 2113756
diff --git a/sysutils/mate-system-monitor/files/patch-src_lsof.cpp b/sysutils/mate-system-monitor/files/patch-src_lsof.cpp
new file mode 100644
index 000000000000..9c32166eb360
--- /dev/null
+++ b/sysutils/mate-system-monitor/files/patch-src_lsof.cpp
@@ -0,0 +1,14 @@
+--- src/lsof.cpp.orig 2015-09-25 13:36:19.000000000 +0200
++++ src/lsof.cpp 2016-01-09 12:32:53.892273000 +0100
+@@ -140,8 +140,9 @@
+
+ void update_count(unsigned count)
+ {
+- string s = static_cast<std::ostringstream&>(std::ostringstream() << count).str();
+- gtk_label_set_text(this->count, s.c_str());
++ std::ostringstream ss;
++ ss << count;;
++ gtk_label_set_text(this->count, ss.str().c_str());
+ }
+
+