aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/mate-system-monitor
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2017-07-04 19:44:30 +0800
committerkwm <kwm@FreeBSD.org>2017-07-04 19:44:30 +0800
commitca99dd95b5868290a96ee47c11645acb4519973c (patch)
tree37169f4d6a1ec15a3f96493c65cb713e58dc7aee /sysutils/mate-system-monitor
parent95c3685fc31f698ba52199a0616cd708f1d9bd15 (diff)
downloadfreebsd-ports-gnome-ca99dd95b5868290a96ee47c11645acb4519973c.tar.gz
freebsd-ports-gnome-ca99dd95b5868290a96ee47c11645acb4519973c.tar.zst
freebsd-ports-gnome-ca99dd95b5868290a96ee47c11645acb4519973c.zip
Update the mate desktop to 1.18.
* The MATE DE is now GTK+3 based * mate-calc has come back. * New USE_MATE=mixer macro * Add license * Review dependancies * Swich to USES=localbase * atril/eom options reworked into option helper Thanks to Eric Turgeon for submitting the bulk of this MATE update. Obtained from: gnome devel repo
Diffstat (limited to 'sysutils/mate-system-monitor')
-rw-r--r--sysutils/mate-system-monitor/Makefile13
-rw-r--r--sysutils/mate-system-monitor/distinfo5
-rw-r--r--sysutils/mate-system-monitor/files/patch-src_lsof.cpp14
-rw-r--r--sysutils/mate-system-monitor/files/patch-src_procproperties.cpp20
-rw-r--r--sysutils/mate-system-monitor/pkg-plist16
5 files changed, 21 insertions, 47 deletions
diff --git a/sysutils/mate-system-monitor/Makefile b/sysutils/mate-system-monitor/Makefile
index f5650a0fe943..a1f5b688d8f9 100644
--- a/sysutils/mate-system-monitor/Makefile
+++ b/sysutils/mate-system-monitor/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mate-system-monitor
-PORTVERSION= 1.12.1
-PORTREVISION= 1
+PORTVERSION= 1.18.0
CATEGORIES= sysutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -17,15 +16,13 @@ LIB_DEPENDS= libgtop-2.0.so:devel/libgtop \
PORTSCOUT= limitw:1,even
-USES= alias compiler:c++11-lang gettext gmake pathfix \
- pkgconfig tar:xz
+USES= alias compiler:c++11-lib gettext gmake localbase \
+ pathfix pkgconfig tar:xz
USE_MATE= icontheme
-USE_GNOME= gtk20 gtkmm24 intlhack librsvg2 libwnck libxml2
-CONFIGURE_ARGS= --with-gtk=2.0
+USE_GNOME= gtkmm30 intlhack librsvg2 libwnck3 libxml2
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-systemd
CONFIGURE_ENV= LIBS="-lutil" DATADIRNAME="share"
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.mate.system-monitor.enums.xml \
org.mate.system-monitor.gschema.xml
diff --git a/sysutils/mate-system-monitor/distinfo b/sysutils/mate-system-monitor/distinfo
index 6b462172d5eb..7d012d618e85 100644
--- a/sysutils/mate-system-monitor/distinfo
+++ b/sysutils/mate-system-monitor/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mate/mate-system-monitor-1.12.1.tar.xz) = 7668ecba70b7f56f3bcfb143cb6b93a15daf8636fcf678491112afea1a49dea9
-SIZE (mate/mate-system-monitor-1.12.1.tar.xz) = 2113756
+TIMESTAMP = 1491689060
+SHA256 (mate/mate-system-monitor-1.18.0.tar.xz) = 887c0d91fa866af75cc066591fcd521107976f123784b1b887535a4709cd9bf1
+SIZE (mate/mate-system-monitor-1.18.0.tar.xz) = 2133484
diff --git a/sysutils/mate-system-monitor/files/patch-src_lsof.cpp b/sysutils/mate-system-monitor/files/patch-src_lsof.cpp
deleted file mode 100644
index 9c32166eb360..000000000000
--- a/sysutils/mate-system-monitor/files/patch-src_lsof.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/lsof.cpp.orig 2015-09-25 13:36:19.000000000 +0200
-+++ src/lsof.cpp 2016-01-09 12:32:53.892273000 +0100
-@@ -140,8 +140,9 @@
-
- void update_count(unsigned count)
- {
-- string s = static_cast<std::ostringstream&>(std::ostringstream() << count).str();
-- gtk_label_set_text(this->count, s.c_str());
-+ std::ostringstream ss;
-+ ss << count;;
-+ gtk_label_set_text(this->count, ss.str().c_str());
- }
-
-
diff --git a/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp b/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp
deleted file mode 100644
index 7daeab5c60d6..000000000000
--- a/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/procproperties.cpp.orig 2015-07-02 23:46:27.000000000 +0200
-+++ src/procproperties.cpp 2015-07-14 10:18:48.273918000 +0200
-@@ -26,7 +26,7 @@
- #include <glibtop/procstate.h>
- #if defined (__linux__)
- #include <asm/param.h>
--#elif defined (__NetBSD__) || defined (__OpenBSD__)
-+#elif defined (__NetBSD__) || defined (__OpenBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
- #include <sys/param.h>
- #include <sys/sysctl.h>
- #endif
-@@ -114,7 +114,7 @@
-
- get_process_memory_info(info);
-
--#if defined (__NetBSD__) || defined (__OpenBSD__)
-+#if defined (__NetBSD__) || defined (__OpenBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
- struct clockinfo cinf;
- size_t size = sizeof (cinf);
- int HZ;
diff --git a/sysutils/mate-system-monitor/pkg-plist b/sysutils/mate-system-monitor/pkg-plist
index 3aa31cd9e7d4..f9ec93af42c8 100644
--- a/sysutils/mate-system-monitor/pkg-plist
+++ b/sysutils/mate-system-monitor/pkg-plist
@@ -1,6 +1,7 @@
bin/mate-system-monitor
+libexec/mate-system-monitor/msm-kill
+libexec/mate-system-monitor/msm-renice
man/man1/mate-system-monitor.1.gz
-share/MateConf/gsettings/mate-system-monitor.convert
share/appdata/mate-system-monitor.appdata.xml
share/applications/mate-system-monitor.desktop
share/help/C/mate-system-monitor/figures/addColumn.png
@@ -219,10 +220,10 @@ share/locale/as/LC_MESSAGES/mate-system-monitor.mo
share/locale/ast/LC_MESSAGES/mate-system-monitor.mo
share/locale/az/LC_MESSAGES/mate-system-monitor.mo
share/locale/be/LC_MESSAGES/mate-system-monitor.mo
-share/locale/be@latin/LC_MESSAGES/mate-system-monitor.mo
share/locale/bg/LC_MESSAGES/mate-system-monitor.mo
share/locale/bn/LC_MESSAGES/mate-system-monitor.mo
share/locale/bn_IN/LC_MESSAGES/mate-system-monitor.mo
+share/locale/br/LC_MESSAGES/mate-system-monitor.mo
share/locale/bs/LC_MESSAGES/mate-system-monitor.mo
share/locale/ca/LC_MESSAGES/mate-system-monitor.mo
share/locale/ca@valencia/LC_MESSAGES/mate-system-monitor.mo
@@ -233,18 +234,20 @@ share/locale/da/LC_MESSAGES/mate-system-monitor.mo
share/locale/de/LC_MESSAGES/mate-system-monitor.mo
share/locale/dz/LC_MESSAGES/mate-system-monitor.mo
share/locale/el/LC_MESSAGES/mate-system-monitor.mo
-share/locale/en@shaw/LC_MESSAGES/mate-system-monitor.mo
share/locale/en_AU/LC_MESSAGES/mate-system-monitor.mo
share/locale/en_CA/LC_MESSAGES/mate-system-monitor.mo
share/locale/en_GB/LC_MESSAGES/mate-system-monitor.mo
share/locale/eo/LC_MESSAGES/mate-system-monitor.mo
share/locale/es/LC_MESSAGES/mate-system-monitor.mo
+share/locale/es_CO/LC_MESSAGES/mate-system-monitor.mo
share/locale/es_MX/LC_MESSAGES/mate-system-monitor.mo
share/locale/et/LC_MESSAGES/mate-system-monitor.mo
share/locale/eu/LC_MESSAGES/mate-system-monitor.mo
share/locale/fa/LC_MESSAGES/mate-system-monitor.mo
share/locale/fi/LC_MESSAGES/mate-system-monitor.mo
share/locale/fr/LC_MESSAGES/mate-system-monitor.mo
+share/locale/fr_CA/LC_MESSAGES/mate-system-monitor.mo
+share/locale/frp/LC_MESSAGES/mate-system-monitor.mo
share/locale/ga/LC_MESSAGES/mate-system-monitor.mo
share/locale/gl/LC_MESSAGES/mate-system-monitor.mo
share/locale/gu/LC_MESSAGES/mate-system-monitor.mo
@@ -252,14 +255,18 @@ share/locale/he/LC_MESSAGES/mate-system-monitor.mo
share/locale/hi/LC_MESSAGES/mate-system-monitor.mo
share/locale/hr/LC_MESSAGES/mate-system-monitor.mo
share/locale/hu/LC_MESSAGES/mate-system-monitor.mo
+share/locale/hy/LC_MESSAGES/mate-system-monitor.mo
share/locale/id/LC_MESSAGES/mate-system-monitor.mo
+share/locale/is/LC_MESSAGES/mate-system-monitor.mo
share/locale/it/LC_MESSAGES/mate-system-monitor.mo
share/locale/ja/LC_MESSAGES/mate-system-monitor.mo
+share/locale/jv/LC_MESSAGES/mate-system-monitor.mo
share/locale/ka/LC_MESSAGES/mate-system-monitor.mo
share/locale/kk/LC_MESSAGES/mate-system-monitor.mo
share/locale/kn/LC_MESSAGES/mate-system-monitor.mo
share/locale/ko/LC_MESSAGES/mate-system-monitor.mo
share/locale/ku/LC_MESSAGES/mate-system-monitor.mo
+share/locale/ku_IQ/LC_MESSAGES/mate-system-monitor.mo
share/locale/ky/LC_MESSAGES/mate-system-monitor.mo
share/locale/li/LC_MESSAGES/mate-system-monitor.mo
share/locale/lt/LC_MESSAGES/mate-system-monitor.mo
@@ -281,6 +288,7 @@ share/locale/oc/LC_MESSAGES/mate-system-monitor.mo
share/locale/or/LC_MESSAGES/mate-system-monitor.mo
share/locale/pa/LC_MESSAGES/mate-system-monitor.mo
share/locale/pl/LC_MESSAGES/mate-system-monitor.mo
+share/locale/pms/LC_MESSAGES/mate-system-monitor.mo
share/locale/ps/LC_MESSAGES/mate-system-monitor.mo
share/locale/pt/LC_MESSAGES/mate-system-monitor.mo
share/locale/pt_BR/LC_MESSAGES/mate-system-monitor.mo
@@ -301,6 +309,7 @@ share/locale/tr/LC_MESSAGES/mate-system-monitor.mo
share/locale/ug/LC_MESSAGES/mate-system-monitor.mo
share/locale/uk/LC_MESSAGES/mate-system-monitor.mo
share/locale/ur/LC_MESSAGES/mate-system-monitor.mo
+share/locale/uz/LC_MESSAGES/mate-system-monitor.mo
share/locale/vi/LC_MESSAGES/mate-system-monitor.mo
share/locale/zh_CN/LC_MESSAGES/mate-system-monitor.mo
share/locale/zh_HK/LC_MESSAGES/mate-system-monitor.mo
@@ -308,3 +317,4 @@ share/locale/zh_TW/LC_MESSAGES/mate-system-monitor.mo
share/pixmaps/mate-system-monitor/download.svg
share/pixmaps/mate-system-monitor/side.png
share/pixmaps/mate-system-monitor/upload.svg
+share/polkit-1/actions/org.mate.mate-system-monitor.policy