aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/mcollective-shell-client
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2014-08-15 23:59:11 +0800
committerrobak <robak@FreeBSD.org>2014-08-15 23:59:11 +0800
commite7bb8b10c68639dc167f0bef8dece1db9d8175b9 (patch)
treed71454545ffb534c66c2fa99b6a9059a7e6dc9c2 /sysutils/mcollective-shell-client
parent059d7722a25908005712604b7752150c421d67df (diff)
downloadfreebsd-ports-gnome-e7bb8b10c68639dc167f0bef8dece1db9d8175b9.tar.gz
freebsd-ports-gnome-e7bb8b10c68639dc167f0bef8dece1db9d8175b9.tar.zst
freebsd-ports-gnome-e7bb8b10c68639dc167f0bef8dece1db9d8175b9.zip
sysutils/mcollective-shell-client: NEW PORT - official MCollecive shell plugin client
Submitted by: Bartek Rutkowski <robak@FreeBSD.org> Approved by: swills (mentor)
Diffstat (limited to 'sysutils/mcollective-shell-client')
-rw-r--r--sysutils/mcollective-shell-client/Makefile37
-rw-r--r--sysutils/mcollective-shell-client/distinfo2
-rw-r--r--sysutils/mcollective-shell-client/pkg-descr9
3 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/mcollective-shell-client/Makefile b/sysutils/mcollective-shell-client/Makefile
new file mode 100644
index 000000000000..c795d50957e6
--- /dev/null
+++ b/sysutils/mcollective-shell-client/Makefile
@@ -0,0 +1,37 @@
+# Created by: Bartek Rutkowski <robak@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mcollective-shell-client
+PORTVERSION= 0.0.1
+CATEGORIES= sysutils
+DISTNAME= mcollective-shell-agent-${PORTVERSION}
+
+MAINTAINER= robak@FreeBSD.org
+COMMENT= MCollective shell client plugin
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= mcollective>=2.2.4:${PORTSDIR}/sysutils/mcollective
+
+WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-mcollective-shell-agent-${GH_COMMIT}
+
+USE_GITHUB= yes
+GH_ACCOUNT= puppetlabs
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 9fb27d5
+
+PLIST_FILES= share/mcollective/application/shell/watcher.rb \
+ share/mcollective/application/shell/prefix_stream_buf.rb \
+ share/mcollective/application/shell.rb
+PLIST_DIRSTRY= share/mcollective/application/shell
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${PLIST_DIRSTRY}
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/application/shell/watcher.rb ${STAGEDIR}${PREFIX}/share/mcollective/application/shell/
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/application/shell/prefix_stream_buf.rb ${STAGEDIR}${PREFIX}/share/mcollective/application/shell/
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/application/shell.rb ${STAGEDIR}${PREFIX}/share/mcollective/application/
+
+.include <bsd.port.mk>
diff --git a/sysutils/mcollective-shell-client/distinfo b/sysutils/mcollective-shell-client/distinfo
new file mode 100644
index 000000000000..f00b7e79917e
--- /dev/null
+++ b/sysutils/mcollective-shell-client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mcollective-shell-agent-0.0.1.tar.gz) = c3e899ecf21508587091828f9e18ed232ca615f9f8a899d524f0b96340738d74
+SIZE (mcollective-shell-agent-0.0.1.tar.gz) = 17900
diff --git a/sysutils/mcollective-shell-client/pkg-descr b/sysutils/mcollective-shell-client/pkg-descr
new file mode 100644
index 000000000000..1f74a3645d90
--- /dev/null
+++ b/sysutils/mcollective-shell-client/pkg-descr
@@ -0,0 +1,9 @@
+The shell client allows you to get commands executed via MCollective's
+mcollective-shell-agent plugin.
+
+It allows the running of long-running processes with a mechanism to check in
+on the output from these long-running processes, which is independent of the
+mcollective daemon process (the daemon can be restarted without interrupting
+the processes)
+
+WWW: https://github.com/puppetlabs/mcollective-shell-agent