aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/mkntpwd/Makefile
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2011-05-18 19:44:14 +0800
committermartymac <martymac@FreeBSD.org>2011-05-18 19:44:14 +0800
commit6878345f3c61cc03c5254815d5e6115ae4321635 (patch)
treec717474f98637ce383f2c8249fbe82aa7a878988 /sysutils/mkntpwd/Makefile
parent0376fc2419beb6d334a99cb63b4dc0d78d52e8f8 (diff)
downloadfreebsd-ports-gnome-6878345f3c61cc03c5254815d5e6115ae4321635.tar.gz
freebsd-ports-gnome-6878345f3c61cc03c5254815d5e6115ae4321635.tar.zst
freebsd-ports-gnome-6878345f3c61cc03c5254815d5e6115ae4321635.zip
Add mkntpwd, a utility to create Samba password hashes
PR: ports/156478 Submitted by: Jyun-Yan You <jyyou at cs.nctu.edu.tw>
Diffstat (limited to 'sysutils/mkntpwd/Makefile')
-rw-r--r--sysutils/mkntpwd/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/sysutils/mkntpwd/Makefile b/sysutils/mkntpwd/Makefile
new file mode 100644
index 000000000000..5076ab062a15
--- /dev/null
+++ b/sysutils/mkntpwd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mkntpwd
+# Date created: 2011-04-18
+# Whom: Jyun-Yan You <jyyou@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mkntpwd
+PORTVERSION= 1.0
+CATEGORIES= sysutils net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ldaputils/Contrib/mkntpwd
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= pcTA@cs.nctu.edu.tw
+COMMENT= A utility to create Samba password hashes
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/mkntpwd
+
+LICENSE= GPLv2 BSD
+LICENSE_COMB= multi
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mkntpwd ${PREFIX}/bin
+
+.include <bsd.port.mk>