aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/mono-kmod/Makefile
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2007-04-21 19:01:11 +0800
committeranray <anray@FreeBSD.org>2007-04-21 19:01:11 +0800
commitbfdd588cbcb266c169c36261f550245e8739865d (patch)
tree5996a4a1bfe7acf9b528c8c6a39bb69e7403d03e /sysutils/mono-kmod/Makefile
parent0785f2dce98e331164759fbbb21d2e518d3e45da (diff)
downloadfreebsd-ports-gnome-bfdd588cbcb266c169c36261f550245e8739865d.tar.gz
freebsd-ports-gnome-bfdd588cbcb266c169c36261f550245e8739865d.tar.zst
freebsd-ports-gnome-bfdd588cbcb266c169c36261f550245e8739865d.zip
mono-kmod is a FreeBSD kernel module enables you to execute ECMA and
.NET applications without preceding the native code generator in the command line. That means you can call a binary with "./hello.exe" instead of "mono hello.exe". WWW: http://www.alpha-tierchen.de/~bkoenig/mono-kmod/ PR: ports/111973 Submitted by: Björn König <bkoenig at cs.tu-berlin.de>
Diffstat (limited to 'sysutils/mono-kmod/Makefile')
-rw-r--r--sysutils/mono-kmod/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/mono-kmod/Makefile b/sysutils/mono-kmod/Makefile
new file mode 100644
index 000000000000..8bd69aa3e6a5
--- /dev/null
+++ b/sysutils/mono-kmod/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: mono-kmod
+# Date created: 14 April 2007
+# Whom: bkoenig@cs.tu-berlin.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= mono-kmod
+PORTVERSION= 20070416
+CATEGORIES= sysutils
+MASTER_SITES= http://www.alpha-tierchen.de/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= bkoenig@cs.tu-berlin.de
+COMMENT= Execute .NET applications from command line
+
+NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
+
+USE_BZIP2= yes
+KMODDIR?= /boot/modules
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PLIST_SUB= KMODDIR=${KMODDIR}
+MAKE_ENV+= KMODDIR=${KMODDIR}
+
+PLIST_FILES= "@cwd %%KMODDIR%%"
+PLIST_FILES+= mono.ko
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>