aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/multitail
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-04-10 05:50:02 +0800
committerobraun <obraun@FreeBSD.org>2003-04-10 05:50:02 +0800
commit0ff9819177ad4fdfdbd4f3ef4e5f9ce36f8234f4 (patch)
treeb9f7990ef71f98ce8c0da2da541d6daeee5ada83 /sysutils/multitail
parentf9c32d398e424399669493d2fb0a96eb51061812 (diff)
downloadfreebsd-ports-gnome-0ff9819177ad4fdfdbd4f3ef4e5f9ce36f8234f4.tar.gz
freebsd-ports-gnome-0ff9819177ad4fdfdbd4f3ef4e5f9ce36f8234f4.tar.zst
freebsd-ports-gnome-0ff9819177ad4fdfdbd4f3ef4e5f9ce36f8234f4.zip
Tail multiple files on console with ncurses.
WWW: http://www.vanheusden.com/multitail/
Diffstat (limited to 'sysutils/multitail')
-rw-r--r--sysutils/multitail/Makefile28
-rw-r--r--sysutils/multitail/distinfo1
-rw-r--r--sysutils/multitail/pkg-descr10
-rw-r--r--sysutils/multitail/pkg-plist1
4 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/multitail/Makefile b/sysutils/multitail/Makefile
new file mode 100644
index 000000000000..f7b8b422dcdf
--- /dev/null
+++ b/sysutils/multitail/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: multitail
+# Date created: 10 April 2003
+# Whom: Oliver Braun <obraun@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= multitail
+PORTVERSION= 1.2
+CATEGORIES= sysutils
+MASTER_SITES= http://www.vanheusden.com/multitail/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= obraun@FreeBSD.org
+COMMENT= Tail multiple files on console with ncurses
+
+USE_REINPLACE= yes
+
+MAN1= multitail.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC/d ; /^CFLAGS/d' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/multitail ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/multitail.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/multitail/distinfo b/sysutils/multitail/distinfo
new file mode 100644
index 000000000000..7348bef641d6
--- /dev/null
+++ b/sysutils/multitail/distinfo
@@ -0,0 +1 @@
+MD5 (multitail-1.2.tgz) = 3fd3013db651378e5bbb99a2ac09010b
diff --git a/sysutils/multitail/pkg-descr b/sysutils/multitail/pkg-descr
new file mode 100644
index 000000000000..9ebfe1e071bd
--- /dev/null
+++ b/sysutils/multitail/pkg-descr
@@ -0,0 +1,10 @@
+Multitail lets you view one or multiple files like the original tail program.
+The difference is that this program creates multiple windows on your console
+(with ncurses). It can also use colors while displaying the logfiles for faster
+recognizing which lines are important and which are not. It is optimized for
+terminal-sessions through slow links.
+
+WWW: http://www.vanheusden.com/multitail/
+
+-- Oliver Braun
+<obraun@FreeBSD.org>
diff --git a/sysutils/multitail/pkg-plist b/sysutils/multitail/pkg-plist
new file mode 100644
index 000000000000..03be0e240820
--- /dev/null
+++ b/sysutils/multitail/pkg-plist
@@ -0,0 +1 @@
+bin/multitail