aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/nctop/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-30 05:10:57 +0800
committeredwin <edwin@FreeBSD.org>2005-12-30 05:10:57 +0800
commitfd1273eb93fc4c68bb7df3f738bc5edf6aeff574 (patch)
tree1d2a22ead31c64116be60e2976964e5323dc218b /sysutils/nctop/Makefile
parent1d9c6fba5830350c1012a8cd0e7c3a347297451d (diff)
downloadfreebsd-ports-gnome-fd1273eb93fc4c68bb7df3f738bc5edf6aeff574.tar.gz
freebsd-ports-gnome-fd1273eb93fc4c68bb7df3f738bc5edf6aeff574.tar.zst
freebsd-ports-gnome-fd1273eb93fc4c68bb7df3f738bc5edf6aeff574.zip
New port: sysutils/nctop
nctop is a remote system monitor for unix hosts. It is a client/server-application using UDP-packets to receive the information of the hosts running the daemon and listed in the clients configuration file. For each host the client displays a line containing: * hostname * load averages * cpu states (sys/user/idle) * real memory usage (used/free/total) * number of users currently logged in WWW: http://www.rz.uni-karlsruhe.de/~hj28/ PR: ports/84521 Submitted by: Ralf Becker <ralf@akk.org>
Diffstat (limited to 'sysutils/nctop/Makefile')
-rw-r--r--sysutils/nctop/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/nctop/Makefile b/sysutils/nctop/Makefile
new file mode 100644
index 000000000000..84f82ed7bcb0
--- /dev/null
+++ b/sysutils/nctop/Makefile
@@ -0,0 +1,32 @@
+# ports collection Makefile for: nctop
+# Date created: 01 August 2005
+# Whom: Ralf Becker <nctop@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nctop
+PORTVERSION= 0.23.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.rz.uni-karlsruhe.de/~hj28/download.php?file=/
+
+MAINTAINER= ralf@akk.org
+COMMENT= A remote system monitor
+
+USE_AUTOTOOLS= autoconf:259:env
+USE_BZIP2= YES
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-libwrap \
+ --with-setgid=kmem
+
+MAN1= nctopd.1 nctop.1
+
+pre-configure:
+ ${CP} ${AUTOCONF_DIR}/install-sh ${WRKSRC}
+ ${CP} ${AUTOCONF_DIR}/config.sub ${WRKSRC}
+ ${CP} ${AUTOCONF_DIR}/config.guess ${WRKSRC}
+ cd ${WRKSRC} && ${AUTOCONF}
+
+.include <bsd.port.mk>