aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/nfsping
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-10-20 08:18:16 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-10-20 08:18:16 +0800
commitc2947ed2599633624c02d5d997109c8577f300fd (patch)
tree61a26ee2da220b4870b48765bba14a56843fe29a /sysutils/nfsping
parent9798be05daab9817a91faf02401562d17a41cdc6 (diff)
downloadfreebsd-ports-gnome-c2947ed2599633624c02d5d997109c8577f300fd.tar.gz
freebsd-ports-gnome-c2947ed2599633624c02d5d997109c8577f300fd.tar.zst
freebsd-ports-gnome-c2947ed2599633624c02d5d997109c8577f300fd.zip
Add sysutils/nfsping
NFSping is a command line utility for measuring the response time of an NFS server. It's basically a copy of the fping interface but doesn't share any code with that project. On modern NFS servers, the network stack and filesystem are often being run on separate cores or even hardware components. This means in practise that a fast ICMP ping response isn't indicative of how quickly the NFS filesystem is responding. This tool more directly tests the responsiveness of the server's operating system's NFS component. WWW: https://github.com/mprovost/NFSping
Diffstat (limited to 'sysutils/nfsping')
-rw-r--r--sysutils/nfsping/Makefile43
-rw-r--r--sysutils/nfsping/distinfo2
-rw-r--r--sysutils/nfsping/files/patch-Makefile38
-rw-r--r--sysutils/nfsping/pkg-descr11
-rw-r--r--sysutils/nfsping/pkg-plist6
5 files changed, 100 insertions, 0 deletions
diff --git a/sysutils/nfsping/Makefile b/sysutils/nfsping/Makefile
new file mode 100644
index 000000000000..d22bac55116f
--- /dev/null
+++ b/sysutils/nfsping/Makefile
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+PORTNAME= nfsping
+PORTVERSION= 0.1.20131017
+CATEGORIES= sysutils net-mgmt
+MASTER_SITES= GH \
+ LOCAL/bdrewery/${PORTNAME}/
+
+MAINTAINER= bdrewery@FreeBSD.org
+COMMENT= Command line tool to check NFS server response times
+
+LICENSE= BSD
+
+OPTIONS_DEFINE= DOCS SMOKEPING
+OPTIONS_DEFAULT=SMOKEPING
+OPTIONS_SUB= yes
+SMOKEPING_DESC= Install Smokeping probe
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= mprovost
+GH_PROJECT= NFSping
+GH_COMMIT= 460c382
+GH_TAGNAME= ${GH_COMMIT}
+
+PORTDOCS= README
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MSMOKEPING}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/smokeping/lib/Smokeping/probes
+ ${INSTALL_DATA} ${WRKSRC}/Smokeping/NFSping.pm \
+ ${STAGEDIR}${PREFIX}/smokeping/lib/Smokeping/probes
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/nfsping/distinfo b/sysutils/nfsping/distinfo
new file mode 100644
index 000000000000..adba3635936e
--- /dev/null
+++ b/sysutils/nfsping/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nfsping-0.1.20131017.tar.gz) = 0ddd7296d57721b0e93e23e1e0f6260f19fa901a723161daef3ebd977ac9755c
+SIZE (nfsping-0.1.20131017.tar.gz) = 27123
diff --git a/sysutils/nfsping/files/patch-Makefile b/sysutils/nfsping/files/patch-Makefile
new file mode 100644
index 000000000000..3714bf7ad0cd
--- /dev/null
+++ b/sysutils/nfsping/files/patch-Makefile
@@ -0,0 +1,38 @@
+--- ./Makefile.orig 2013-10-19 17:19:23.064145798 -0500
++++ ./Makefile 2013-10-19 17:19:37.904136233 -0500
+@@ -3,27 +3,27 @@
+ CFLAGS=-Werror -g -I src -I.
+
+ nfsping: src/nfsping.c src/nfsping.h src/nfs_prot_clnt.c src/mount_clnt.c src/util.c src/rpc.c
+- gcc ${CFLAGS} src/nfsping.c src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/mount_clnt.c src/mount_xdr.c src/util.c src/rpc.c -o $@
++ $(CC) ${CFLAGS} src/nfsping.c src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/mount_clnt.c src/mount_xdr.c src/util.c src/rpc.c -o $@
+
+ src/nfs_prot.h src/nfs_prot_clnt.c src/nfs_prot_svc.c src/nfs_prot_xdr.c: src/nfs_prot.x
+- rpcgen -DWANT_NFS3 $<
++ cd src && rpcgen -DWANT_NFS3 `basename $<`
+
+ src/mount.h src/mount_clnt.c src/mount_svc.c src/mount_xdr.c: src/mount.x
+- rpcgen -DWANT_NFS3 $<
++ cd src && rpcgen -DWANT_NFS3 `basename $<`
+
+ nfsmount: src/mount.c src/nfsping.h src/mount_clnt.c src/mount_xdr.c src/rpc.c
+- gcc ${CFLAGS} $^ -o $@
++ $(CC) ${CFLAGS} $^ -o $@
+
+ nfsdf: src/df.c src/nfsping.h src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/util.c
+- gcc ${CFLAGS} $^ -o $@
++ $(CC) ${CFLAGS} $^ -o $@
+
+ nfsls: src/ls.c src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/util.c src/rpc.c
+- gcc ${CFLAGS} $^ -o $@
++ $(CC) ${CFLAGS} $^ -o $@
+
+ nfscat: src/cat.c src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/util.c src/rpc.c
+- gcc ${CFLAGS} $^ -o $@
++ $(CC) ${CFLAGS} $^ -o $@
+
+ tests: tests/util_tests
+
+ tests/util_tests: tests/util_tests.c tests/minunit.h src/util.c src/util.h
+- gcc ${CFLAGS} tests/util_tests.c src/util.c -o $@
++ $(CC) ${CFLAGS} tests/util_tests.c src/util.c -o $@
diff --git a/sysutils/nfsping/pkg-descr b/sysutils/nfsping/pkg-descr
new file mode 100644
index 000000000000..1c81c0a6ad93
--- /dev/null
+++ b/sysutils/nfsping/pkg-descr
@@ -0,0 +1,11 @@
+NFSping is a command line utility for measuring the response time of an NFS
+server. It's basically a copy of the fping interface but doesn't share any code
+with that project.
+
+On modern NFS servers, the network stack and filesystem are often being run on
+separate cores or even hardware components. This means in practise that a fast
+ICMP ping response isn't indicative of how quickly the NFS filesystem is
+responding. This tool more directly tests the responsiveness of the server's
+operating system's NFS component.
+
+WWW: https://github.com/mprovost/NFSping
diff --git a/sysutils/nfsping/pkg-plist b/sysutils/nfsping/pkg-plist
new file mode 100644
index 000000000000..7835867f7537
--- /dev/null
+++ b/sysutils/nfsping/pkg-plist
@@ -0,0 +1,6 @@
+bin/nfsping
+%%SMOKEPING%%smokeping/lib/Smokeping/probes/NFSping.pm
+%%SMOKEPING%%@dirrmtry smokeping/lib/Smokeping/probes
+%%SMOKEPING%%@dirrmtry smokeping/lib/Smokeping
+%%SMOKEPING%%@dirrmtry smokeping/lib
+%%SMOKEPING%%@dirrmtry smokeping