aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/nitrogen/Makefile
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-31 10:29:50 +0800
committerrafan <rafan@FreeBSD.org>2007-07-31 10:29:50 +0800
commit395b51d7a1e14381904d95cc89d074767c6e0940 (patch)
tree5fd9bd2fda9291b052e4e823dd0c3fc755430a1e /sysutils/nitrogen/Makefile
parent6fa28a6e2120184f55909f1f62dbced236229576 (diff)
downloadfreebsd-ports-gnome-395b51d7a1e14381904d95cc89d074767c6e0940.tar.gz
freebsd-ports-gnome-395b51d7a1e14381904d95cc89d074767c6e0940.tar.zst
freebsd-ports-gnome-395b51d7a1e14381904d95cc89d074767c6e0940.zip
Nitrogen is a background browser and setter for X windows. It is written
in C++ using the gtkmm toolkit. WWW: http://l3ib.org/nitrogen PR: ports/114282 Submitted by: Jonathan Liu <Net147 at hotmail.com>
Diffstat (limited to 'sysutils/nitrogen/Makefile')
-rw-r--r--sysutils/nitrogen/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/sysutils/nitrogen/Makefile b/sysutils/nitrogen/Makefile
new file mode 100644
index 000000000000..5f976861bb38
--- /dev/null
+++ b/sysutils/nitrogen/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: nitrogen
+# Date created: 4 July 3007
+# Whom: Jonathan Liu <Net147@hotmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nitrogen
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://l3ib.org/nitrogen/files/ \
+ http://www.sourcefiles.org/Toys/Candy/
+
+MAINTAINER= Net147@hotmail.com
+COMMENT= Background browser and setter for X windows
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
+RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme \
+ ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+
+USE_GNOME= gtk20
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-inotify
+CXXFLAGS+= -I${X11BASE}/include -L${X11BASE}/lib
+
+OPTIONS= XINERAMA "Xinerama support" on
+
+MAN1= nitrogen.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_XINERAMA)
+CONFIGURE_ARGS+=--disable-xinerama
+.else
+CONFIGURE_ARGS+=--enable-xinerama
+LIB_DEPENDS+= Xinerama:${PORTSDIR}/x11/libXinerama
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,#!/bin/bash,#!${LOCALBASE}/bin/bash,' \
+ ${WRKSRC}/data/icon-theme-installer
+
+.include <bsd.port.post.mk>