aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ntfsprogs/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2004-05-10 00:06:23 +0800
committernork <nork@FreeBSD.org>2004-05-10 00:06:23 +0800
commit9fb1130cde1628ba2fe8b1a7f19a8f8be6ccf209 (patch)
tree2b2e12b347df2778b492045caca1d9015ef5fe8d /sysutils/ntfsprogs/Makefile
parent178885a4b1549f8a0f11a6bf0fe450a821f3e049 (diff)
downloadfreebsd-ports-gnome-9fb1130cde1628ba2fe8b1a7f19a8f8be6ccf209.tar.gz
freebsd-ports-gnome-9fb1130cde1628ba2fe8b1a7f19a8f8be6ccf209.tar.zst
freebsd-ports-gnome-9fb1130cde1628ba2fe8b1a7f19a8f8be6ccf209.zip
Add ntfsprogs 1.9.1, utilities and library to manipulate NTFS
partitions. PR: ports/66406 Submitted by: Florent Thoumie <flz@xbsd.org>
Diffstat (limited to 'sysutils/ntfsprogs/Makefile')
-rw-r--r--sysutils/ntfsprogs/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
new file mode 100644
index 000000000000..eb6e28b25464
--- /dev/null
+++ b/sysutils/ntfsprogs/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: ntfsprogs
+# Date created: May 8 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ntfsprogs
+PORTVERSION= 1.9.1
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= linux-ntfs
+
+MAINTAINER= flz@xbsd.org
+COMMENT= Utilities and library to manipulate NTFS partitions
+
+GNU_CONFIGURE= yes
+USE_GCC= 3.3
+USE_REINPLACE= yes
+
+MAN8= mkntfs.8 \
+ ntfscat.8 \
+ ntfsclone.8 \
+ ntfscluster.8 \
+ ntfsfix.8 \
+ ntfsinfo.8 \
+ ntfslabel.8 \
+ ntfsls.8 \
+ ntfsprogs.8 \
+ ntfsresize.8 \
+ ntfsundelete.8
+
+.if defined(WITH_GNOMEVFS2)
+USE_GNOME= gnomevfs2
+PLIST_SUB= GNOMEVFS2=""
+MAN8+= libntfs-gnomevfs.8
+.else
+CONFIGURE_ARGS= --disable-gnome-vfs
+PLIST_SUB= GNOMEVFS2="@comment "
+.endif
+
+.if !defined(WITH_GNOMEVFS2)
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You can define the following for additional features:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WITH_GNOMEVFS2 - Installs Gnome-VFS-2.0 libntfs interface.
+ @${ECHO_MSG} ""
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^transform.*||' ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/libntfs/Makefile.in \
+ ${WRKSRC}/ntfsprogs/Makefile.in
+
+.include <bsd.port.mk>