aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/nut/Makefile
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2007-10-07 17:13:49 +0800
committermm <mm@FreeBSD.org>2007-10-07 17:13:49 +0800
commit1e600ffe6af6fa4a48d1d5b2a1f8f90827cd9723 (patch)
tree6c5bedf602350a82fad041bed3b7d67663bb2e50 /sysutils/nut/Makefile
parent88f9c09c9976dc3ac2c69ab87fe8415caf611625 (diff)
downloadfreebsd-ports-gnome-1e600ffe6af6fa4a48d1d5b2a1f8f90827cd9723.tar.gz
freebsd-ports-gnome-1e600ffe6af6fa4a48d1d5b2a1f8f90827cd9723.tar.zst
freebsd-ports-gnome-1e600ffe6af6fa4a48d1d5b2a1f8f90827cd9723.zip
- Upgrade to 2.2.0
PR: ports/115898 Submitted by: mm Approved by: maintainer (timeout)
Diffstat (limited to 'sysutils/nut/Makefile')
-rw-r--r--sysutils/nut/Makefile131
1 files changed, 61 insertions, 70 deletions
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index ec0c486bbd16..c3dcd9404b9e 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -6,39 +6,27 @@
#
PORTNAME= nut
-PORTVERSION= 2.0.5
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= sysutils
-MASTER_SITES= http://eu1.networkupstools.org/source/${PORTVERSION:R}/ \
- http://us1.networkupstools.org/source/${PORTVERSION:R}/
+MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= Joerg.Pulz@frm2.tum.de
-COMMENT?= Network UPS Tools
-
-SUBSYS?= base
-.if ${SUBSYS} != base
-PKGNAMESUFFIX= -${SUBSYS}
-.endif
+COMMENT= Network UPS Tools
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
- --localstatedir=${STATEDIR} \
- --datadir=${PREFIX}/etc/nut \
- --with-drvpath=${PREFIX}/libexec/nut \
- --with-statepath=${STATEDIR} \
- --with-altpidpath=${STATEDIR} \
- --with-pidpath=${STATEDIR} \
- --with-linux-hiddev=no \
- --with-user=${NUT_USER}
+USE_GMAKE= yes
NUT_USER?= uucp
-STATEDIR= /var/db/nut
+NUT_GROUP?= uucp
+STATEDIR?= /var/db/nut
-.include <bsd.port.pre.mk>
+OPTIONS= USB "USB support" on \
+ SNMP "SNMP support" on \
+ LIBUPSCLIENT "Include the libupsclient library" off \
+ CGI "Web CGI interface" off \
-.if ${SUBSYS} == base
USE_RC_SUBR= nut.sh nut_upsmon.sh nut_upslog.sh
SUB_LIST+= STATEDIR=${STATEDIR}
PLIST_SUB+= STATEDIR=${STATEDIR}
@@ -47,20 +35,31 @@ MAN5= ups.conf.5 upsd.conf.5 upsd.users.5 upsmon.conf.5 \
upssched.conf.5
MAN8= al175.8 apcsmart.8 bcmxcp.8 belkin.8 belkinunv.8 \
bestuferrups.8 bestups.8 bestfcom.8 cpsups.8 cyberpower.8 \
- dummy-ups.8 etapro.8 everups.8 fentonups.8 genericups.8 \
- ippon.8 isbmex.8 liebert.8 masterguard.8 megatec.8 metasys.8 \
- mge-shut.8 mge-utalk.8 mustek.8 nitram.8 nutupsdrv.8 oneac.8 \
- optiups.8 powercom.8 powerpanel.8 safenet.8 sms.8 solis.8 \
- tripplite.8 tripplitesu.8 upsc.8 upscmd.8 upscode2.8 upsd.8 \
- upsdrvctl.8 upslog.8 upsmon.8 upsrw.8 upssched.8 victronups.8
+ dummy-ups.8 etapro.8 everups.8 gamatronic.8 genericups.8 \
+ isbmex.8 liebert.8 masterguard.8 megatec.8 metasys.8 \
+ mge-shut.8 mge-utalk.8 nitram.8 nutupsdrv.8 oneac.8 optiups.8 \
+ powercom.8 powerpanel.8 rhino.8 safenet.8 solis.8 tripplite.8 \
+ tripplitesu.8 upsc.8 upscmd.8 upscode2.8 upsd.8 upsdrvctl.8 \
+ upslog.8 upsmon.8 upsrw.8 upssched.8 victronups.8
+
+PORTDOCS= *
-ALL_TARGET= all
-INSTALL_TARGET= install install-conf
+.include <bsd.port.pre.mk>
-.if defined(WITH_NUT_CGI)
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
+ --program-transform-name="" \
+ --localstatedir=${STATEDIR} \
+ --datadir=${PREFIX}/etc/nut \
+ --with-drvpath=${PREFIX}/libexec/nut \
+ --with-statepath=${STATEDIR} \
+ --with-altpidpath=${STATEDIR} \
+ --with-pidpath=${STATEDIR} \
+ --with-linux-hiddev=no \
+ --with-user=${NUT_USER} \
+ --with-group=${NUT_GROUP}
+
+.if defined(WITH_CGI)
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
-ALL_TARGET+= cgi
-INSTALL_TARGET+=install-cgi install-cgi-conf
MAN5+= hosts.conf.5 upsset.conf.5 upsstats.html.5
MAN8+= upsset.cgi.8 upsstats.cgi.8 upsimage.cgi.8
.if !exists(${PREFIX}/www) && exists(${PREFIX}/share/apache)
@@ -74,58 +73,52 @@ CONFIGURE_ARGS+= --with-cgi --with-cgipath=${PREFIX}/${CGIDIR}/nut \
--with-htmlpath=${PREFIX}/${WWWDIR}/nut \
--with-gd-includes=-I${PREFIX}/include \
--with-gd-libs="-L${PREFIX}/lib -lgd"
-PLIST_SUB+= WWWFILES="${WWWDIR}/nut/"
-PLIST_SUB+= WWWDIRRM="@dirrm ${WWWDIR}/nut"
-PLIST_SUB+= CGIFILES="${CGIDIR}/nut/"
-PLIST_SUB+= CGIDIRRM="@dirrm ${CGIDIR}/nut"
-PLIST_SUB+= CGIETC="etc/nut/"
+PLIST_SUB+= NUT_CGI=""
+PLIST_SUB+= WWWDIR="${WWWDIR}"
+PLIST_SUB+= CGIDIR="${CGIDIR}"
+PLIST_SUB+= CGIETCDIR="etc/nut/"
.else
-PLIST_SUB+= WWWFILES="@comment "
-PLIST_SUB+= WWWDIRRM="@comment "
-PLIST_SUB+= CGIFILES="@comment "
-PLIST_SUB+= CGIDIRRM="@comment "
-PLIST_SUB+= CGIETC="@comment "
-.endif
+CONFIGURE_ARGS+= --without-cgi
+PLIST_SUB+= NUT_CGI="@comment "
.endif
-.if ${SUBSYS} == usb
+.if !defined(WITHOUT_USB)
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-ALL_TARGET= usb
-INSTALL_TARGET= install-usb
-
-MAN8= bcmxcp_usb.8 newhidups.8 tripplite_usb.8
+CONFIGURE_ARGS+= --with-usb=auto
+MAN8+= bcmxcp_usb.8 megatec_usb.8 tripplite_usb.8 usbhid-ups.8
+PLIST_SUB+= NUT_USB=""
+.else
+CONFIGURE_ARGS+= --without-usb
+PLIST_SUB+= NUT_USB="@comment "
.endif
-.if ${SUBSYS} == snmp
+.if !defined(WITHOUT_SNMP)
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
-ALL_TARGET= snmp
-INSTALL_TARGET= install-snmp
-
-MAN8= snmp-ups.8
+CONFIGURE_ARGS+= --with-snmp
+MAN8+= snmp-ups.8
+PLIST_SUB+= NUT_SNMP=""
+.else
+CONFIGURE_ARGS+= --without-snmp
+PLIST_SUB+= NUT_SNMP="@comment "
.endif
-.if ${SUBSYS} == libupsclient
-CONFIGURE_ARGS+= --enable-pkg-config \
+.if defined(WITH_LIBUPSCLIENT)
+CONFIGURE_ARGS+= --with-lib --enable-pkg-config \
--with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig
-ALL_TARGET= lib
-INSTALL_TARGET= install-lib
-MAN3= upscli_connect.3 upscli_disconnect.3 upscli_readline.3 \
+MAN3+= upscli_connect.3 upscli_disconnect.3 upscli_readline.3 \
upscli_sendline.3 upscli_splitname.3 upscli_strerror.3
-post-patch:
- @${REINPLACE_CMD} -e "s#@PKG_CFG_DIR@#${PREFIX}/libdata/pkgconfig#g" \
- ${WRKSRC}/lib/Makefile.in
+PLIST_SUB+= NUT_LIB=""
+.else
+CONFIGURE_ARGS+= --without-lib
+PLIST_SUB+= NUT_LIB="@comment "
.endif
-.if ${SUBSYS} == base
pre-install:
-.if !defined(WITH_NUT_CGI) && !defined(BATCH) && !defined(PACKAGE_BUILDING)
- @${ECHO_MSG} "Type \"make -DWITH_NUT_CGI\" if you want to build CGI scripts."
-.endif
@${MKDIR} ${PREFIX}/libexec/nut
@${MKDIR} ${STATEDIR}
- @${CHOWN} ${NUT_USER}:wheel ${STATEDIR}
+ @${CHOWN} ${NUT_USER}:${NUT_GROUP} ${STATEDIR}
@${CHMOD} 0750 ${STATEDIR}
.if !defined(NOPORTDOCS)
@@ -134,11 +127,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/docs/cables/*.txt ${DOCSDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/FAQ ${DOCSDIR}
-.for file in ChangeLog CREDITS INSTALL NEWS README UPGRADING
+.for file in AUTHORS COPYING ChangeLog INSTALL MAINTAINERS NEWS README UPGRADING
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.endif
-
.include <bsd.port.post.mk>
edfast2001-05-244-4/+166 * Finished porting from the old event-editor.c. Made it store a clone of theFederico Mena Quintero2001-05-248-29/+1229 * New async function to remove a folder. God knows if it does what theJeffrey Stedfast2001-05-244-11/+201 * Remove reference to verify-evolution-install.sh since it doesn't work anyDan Winship2001-05-243-27/+57 * Updated Japanese translationAkira TAGOH2001-05-232-350/+406 * Mark a string for translation.Kjartan Maraas2001-05-232-1/+6 * s/evolution-vcard-import/evolution-vcard-importerKjartan Maraas2001-05-232-1/+5 * Untabify.Ettore Perazzoli2001-05-232-1464/+1464 * Add Emacs-like local variable settings to disable `indent-tabs-mode'.Ettore Perazzoli2001-05-232-2/+10 * More (minor) indentation fixes.Ettore Perazzoli2001-05-232-14/+14 * Re-indented the FAQ document.Ettore Perazzoli2001-05-234-876/+850 * set orig to 0Radek Doulik2001-05-232-0/+5 * track change to the path to the ComponentPlaceholder.Chris Toshok2001-05-232-1/+7 * fix strings such that ones that happening at the beginning or during anChris Toshok2001-05-233-8/+31 * add sequence_complete_id to EAddressbookModel and stop_state_changed toChris Toshok2001-05-235-12/+101 * allow NULL pixbufs, and draw with crappy alphajacob berkman2001-05-231-33/+17 * Save the message-display style. (config_read): Read the message-displayJeffrey Stedfast2001-05-233-3/+23 * Made this faster in some cases.Christopher James Lahey2001-05-231-1/+1 * If http mode is HTTP_SOMETIMES, use e_book_query_address_locally to checkDan Winship2001-05-233-9/+46 * ref the listener for the duration of this function, since emittingDan Winship2001-05-232-0/+15 * Use MAILER_CFLAGS and MAILER_LIBS.Jeffrey Stedfast2001-05-233-7/+5 * Create MAILER_CFLAGS and MAILER_LIBS so that we don't have the same libsJeffrey Stedfast2001-05-232-0/+11 * Instead of calling message_list_select_uid() here, instead connect to theJeffrey Stedfast2001-05-234-9/+47 * The double_click signal on the table item now emits the model row insteadChristopher James Lahey2001-05-231-2/+1 * a similar change to below, which makes it actually work for the case wherejacob berkman2001-05-221-1/+1 * Updated Hungarian translation (andras)Szabolcs Ban2001-05-222-125/+150 * track the change in evolution-addressbook.xml's bonobo ui path's.Chris Toshok2001-05-222-6/+10 * make the name of menuitem/toolitem's the same as the verb to save us fromChris Toshok2001-05-222-23/+25 * fixed bad shadowJakub Steiner2001-05-222-0/+4 * Added evolution-faq as an entity.Aaron Weber2001-05-226-1074/+1196 * correct typo.Chris Toshok2001-05-222-1/+5 * make the view menuitems radio items of the same group, and allocate theChris Toshok2001-05-222-52/+85 * doc/C/evolution.sgml - Pulled my name from copyright listKevin Breit2001-05-222-2/+0 * update_view_type is gone, since the menu item is gone.Chris Toshok2001-05-223-52/+12 * remove ViewAsTable menu item.Chris Toshok2001-05-222-7/+4 * increment row each time through the loop so we don't get @count copies ofChris Toshok2001-05-221-0/+1 * Store the CamelFolderInfo tree that was returned fromJeffrey Stedfast2001-05-223-5/+17 * Fix bug #2831; the tasks toolbar and menu now have a button to delete theFederico Mena Quintero2001-05-226-59/+213 * Added a Delete button on the toolbar.Federico Mena Quintero2001-05-222-17/+13 * Mark a string for translation.Kjartan Maraas2001-05-222-2/+6 * Updated Spanish translation.Hector Garcia2001-05-222-1096/+1816 * fixed multibytePablo Saratxaga2001-05-222-9/+4 * Updated. Updated Norwegian translation.Kjartan Maraas2001-05-213-25/+49 * Updated Norwegian translation.Kjartan Maraas2001-05-212-503/+654 * Updated Hungarian translation (andras)Szabolcs Ban2001-05-212-787/+1126 * Removed an unused variable.Christopher James Lahey2001-05-215-3/+19 * Add in evolution-vcard-importer as part of the list of processes toDuncan Mak2001-05-212-0/+7 * Add a button and an icon to toggle between online and offlineEttore Perazzoli2001-05-214-23/+207 * Implemented the "Copy Folder" and "Move Folder" menu items. Untested.Ettore Perazzoli2001-05-205-12/+302 * Updated to ignore more built files.Ettore Perazzoli2001-05-202-12/+16 * This should fix that irritatingJody Goldberg2001-05-202-0/+7 * Add a caption to the folder selection dialog widget, and get theEttore Perazzoli2001-05-206-10/+67 * Renamed the "NewWindow" verb into "OpenFolderInNewWindow". Got theEttore Perazzoli2001-05-196-69/+103 * Killed a warning here. (model_changed, items_inserted): Check if we'reChristopher James Lahey2001-05-191-7/+5 * German translation updatesMatthias Warkus2001-05-192-1084/+1568 * Create new files for the folder commands, and move the "Create newEttore Perazzoli2001-05-195-12/+181 * Modify `e_gethostbyname_r()' so that it doesn't report an error if theEttore Perazzoli2001-05-192-1/+17 * Updated Japanese translation.Akira TAGOH2001-05-19