aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/nut22
diff options
context:
space:
mode:
authorbp <bp@FreeBSD.org>2000-01-11 19:55:48 +0800
committerbp <bp@FreeBSD.org>2000-01-11 19:55:48 +0800
commit327057a0fb65e97fdf7add79a1f76de1e92c3890 (patch)
tree927fb491b6da92b269dd4328f3005956ee2ae3a2 /sysutils/nut22
parent181b051358e152d86a57fd922803d1c205ab661c (diff)
downloadfreebsd-ports-gnome-327057a0fb65e97fdf7add79a1f76de1e92c3890.tar.gz
freebsd-ports-gnome-327057a0fb65e97fdf7add79a1f76de1e92c3890.tar.zst
freebsd-ports-gnome-327057a0fb65e97fdf7add79a1f76de1e92c3890.zip
New port for 'nut' package. It supports wide variety of UPS hardware
(including Smart and Back UPS for APPC), has ability to shutdown multiple hosts without additional hardware and provides CGI scripts to monitor UPS status via WEB interface.
Diffstat (limited to 'sysutils/nut22')
-rw-r--r--sysutils/nut22/Makefile64
-rw-r--r--sysutils/nut22/distinfo1
-rw-r--r--sysutils/nut22/files/patch-aa54
-rw-r--r--sysutils/nut22/pkg-comment1
-rw-r--r--sysutils/nut22/pkg-descr7
-rw-r--r--sysutils/nut22/pkg-plist17
-rw-r--r--sysutils/nut22/pkg-plist.cgi6
-rw-r--r--sysutils/nut22/pkg-plist.doc14
8 files changed, 164 insertions, 0 deletions
diff --git a/sysutils/nut22/Makefile b/sysutils/nut22/Makefile
new file mode 100644
index 000000000000..55b81bdf9fba
--- /dev/null
+++ b/sysutils/nut22/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: nut
+# Version required: nut-0.42.1
+# Date created: 08 Jan 2000
+# Whom: Boris Popov <bp@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= nut-0.42.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.exploits.org/nut/release/
+
+MAINTAINER= bp@butya.kz
+
+.if defined(CGI)
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-celsius --sysconfdir=${PREFIX}/etc/nut \
+ --with-uid=65534 --with-gid=68
+ALL_TARGET= all
+
+PLIST= ${WRKDIR}/PLIST.DYN
+
+NDOCDIR= ${PREFIX}/share/doc/nut
+
+.if defined(CGI)
+NCGIDIR= ${PREFIX}/share/nut/cgi
+ALL_TARGET+= cgi
+.endif
+
+pre-fetch:
+.if !defined(CGI)
+ @${ECHO_MSG} "Type \"make CGI=yes\" if you want to build CGI scripts."
+.endif
+
+pre-install:
+ @cp ${PKGDIR}/PLIST ${WRKDIR}/PLIST.DYN
+.if !defined(NOPORSDOCS)
+ @cat ${PKGDIR}/PLIST.DOC >> ${WRKDIR}/PLIST.DYN
+.endif
+.if defined(CGI)
+ @cat ${PKGDIR}/PLIST.CGI >> ${WRKDIR}/PLIST.DYN
+.endif
+
+post-install:
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/upsd.sh.sample \
+ >${PREFIX}/etc/rc.d/upsd.sh.sample
+ @${CHMOD} 0755 ${PREFIX}/etc/rc.d/upsd.sh.sample
+.if !defined(NOPORTDOCS)
+ @if ! [ -d ${NDOCDIR} ]; then ${MKDIR} ${NDOCDIR}; fi
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${NDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${NDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/QUICKSTART ${NDOCDIR}
+.endif
+.if defined(CGI)
+ @if ! [ -d ${NCGIDIR} ]; then ${MKDIR} ${NCGIDIR}; fi
+ ${INSTALL_DATA} ${WRKSRC}/clients/*.cgi ${NCGIDIR}
+ @${ECHO_MSG} "Look in ${NCGIDIR} for cgi scripts."
+.endif
+ @${ECHO_MSG} "Look in ${NDOCDIR} for documentation."
+
+.include <bsd.port.mk>
diff --git a/sysutils/nut22/distinfo b/sysutils/nut22/distinfo
new file mode 100644
index 000000000000..88c3d4257310
--- /dev/null
+++ b/sysutils/nut22/distinfo
@@ -0,0 +1 @@
+MD5 (nut-0.42.1.tar.gz) = 56edd3af2de100680962585a1bd02bbc
diff --git a/sysutils/nut22/files/patch-aa b/sysutils/nut22/files/patch-aa
new file mode 100644
index 000000000000..043bed9cc5bf
--- /dev/null
+++ b/sysutils/nut22/files/patch-aa
@@ -0,0 +1,54 @@
+--- clients/Makefile.in.org Wed Nov 10 01:36:44 1999
++++ clients/Makefile.in Mon Jan 10 16:43:44 2000
+@@ -53,8 +53,8 @@
+
+ install: all
+ @for p in $(PROGS) ; do \
+- echo cp $$p $(BASEPATH)/bin; \
+- cp $$p $(BASEPATH)/bin; \
++ echo cp $$p $(BASEPATH)/sbin; \
++ cp $$p $(BASEPATH)/sbin; \
+ done
+
+ install-cgi: cgi
+
+--- conf/Makefile.in.org Mon Oct 18 03:56:11 1999
++++ conf/Makefile.in Tue Jan 11 16:57:15 2000
+@@ -9,10 +9,6 @@
+
+ install:
+ @for f in $(CONFFILES) ; do \
+- if [ -f $(CONFPATH)/$$f ]; then \
+- echo "Preserving existing config file: $$f"; \
+- else \
+- echo cp $$f $(CONFPATH); \
+- cp $$f $(CONFPATH); \
+- fi; \
++ echo cp $$f $(CONFPATH)/$$f.sample; \
++ cp $$f $(CONFPATH)/$$f.sample; \
+ done
+
+--- server/Makefile.in.org Wed Nov 10 01:37:01 1999
++++ server/Makefile.in Mon Jan 10 16:41:55 2000
+@@ -21,6 +21,6 @@
+
+ install: all
+ @for p in $(PROGS) ; do \
+- echo cp $$p $(BASEPATH)/bin ; \
+- cp $$p $(BASEPATH)/bin; \
++ echo cp $$p $(BASEPATH)/sbin ; \
++ cp $$p $(BASEPATH)/sbin; \
+ done
+
+--- models/Makefile.in.org Wed Nov 10 01:36:44 1999
++++ models/Makefile.in Mon Jan 10 16:43:44 2000
+@@ -35,6 +35,6 @@
+
+ install: all
+ @for p in $(PROGS) ; do \
+- echo cp $$p $(BASEPATH)/bin; \
+- cp $$p $(BASEPATH)/bin; \
++ echo cp $$p $(BASEPATH)/sbin; \
++ cp $$p $(BASEPATH)/sbin; \
+ done
+
diff --git a/sysutils/nut22/pkg-comment b/sysutils/nut22/pkg-comment
new file mode 100644
index 000000000000..83ab91a03e2d
--- /dev/null
+++ b/sysutils/nut22/pkg-comment
@@ -0,0 +1 @@
+Network UPS Tools
diff --git a/sysutils/nut22/pkg-descr b/sysutils/nut22/pkg-descr
new file mode 100644
index 000000000000..cfc898ce8095
--- /dev/null
+++ b/sysutils/nut22/pkg-descr
@@ -0,0 +1,7 @@
+This is a developing project to monitor a large assortment of UPS hardware.
+Network communications are used so that multiple systems can monitor a
+single physical UPS and shut down together if necessary without any
+special "sharing hardware" on the UPS itself. CGI scripts provided
+to monitor UPS status via WEB browser.
+
+WWW: http://www.exploits.org/nut/
diff --git a/sysutils/nut22/pkg-plist b/sysutils/nut22/pkg-plist
new file mode 100644
index 000000000000..a084e0afe08a
--- /dev/null
+++ b/sysutils/nut22/pkg-plist
@@ -0,0 +1,17 @@
+sbin/apcsmart
+sbin/genericups
+sbin/optiups
+sbin/bestups
+sbin/ups-trust425+625
+sbin/fentonups
+sbin/upsc
+sbin/upslog
+sbin/upsmon
+sbin/upsct
+sbin/upsct2
+sbin/upsd
+etc/nut/hosts.conf.sample
+etc/nut/multimon.conf.sample
+etc/nut/upsd.conf.sample
+etc/nut/upsmon.conf.sample
+etc/rc.d/upsd.sh.sample
diff --git a/sysutils/nut22/pkg-plist.cgi b/sysutils/nut22/pkg-plist.cgi
new file mode 100644
index 000000000000..670b38eca27c
--- /dev/null
+++ b/sysutils/nut22/pkg-plist.cgi
@@ -0,0 +1,6 @@
+share/nut/cgi/multimon.cgi
+share/nut/cgi/upsimage.cgi
+share/nut/cgi/upsset.cgi
+share/nut/cgi/upsstats.cgi
+@dirrm share/nut/cgi
+@dirrm share/nut
diff --git a/sysutils/nut22/pkg-plist.doc b/sysutils/nut22/pkg-plist.doc
new file mode 100644
index 000000000000..7c904e08fa3c
--- /dev/null
+++ b/sysutils/nut22/pkg-plist.doc
@@ -0,0 +1,14 @@
+share/doc/nut/FAQ
+share/doc/nut/access.txt
+share/doc/nut/commands.txt
+share/doc/nut/generic-ups.txt
+share/doc/nut/new-modules.txt
+share/doc/nut/pager.txt
+share/doc/nut/protocol.txt
+share/doc/nut/shutdown.txt
+share/doc/nut/tips.txt
+share/doc/nut/todo.txt
+share/doc/nut/ups-trust425+625.txt
+share/doc/nut/README
+share/doc/nut/QUICKSTART
+@dirrm share/doc/nut