aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ori
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-06-21 13:58:33 +0800
committerjgh <jgh@FreeBSD.org>2013-06-21 13:58:33 +0800
commit3adb2965868a7180ffa7060b03142eeded89a25f (patch)
tree9aaaba46bd4a8063512353503ee80a1db695dce1 /sysutils/ori
parentf00fb6b8ec8a85238585f54a8545c9c3717ce851 (diff)
downloadfreebsd-ports-gnome-3adb2965868a7180ffa7060b03142eeded89a25f.tar.gz
freebsd-ports-gnome-3adb2965868a7180ffa7060b03142eeded89a25f.tar.zst
freebsd-ports-gnome-3adb2965868a7180ffa7060b03142eeded89a25f.zip
Ori is a distributed file system built for offline operation and empowers the
user with control over synchronization operations and conflict resolution. We provide history through light weight snapshots and allow users to verify the history has not been tampered with. Through the use of replication instances can be resilient and recover damaged data from other nodes. WWW: http://ori.scs.stanford.edu/ PR: ports/176429 Submitted by: mashti@cs.stanford.edu
Diffstat (limited to 'sysutils/ori')
-rw-r--r--sysutils/ori/Makefile40
-rw-r--r--sysutils/ori/distinfo2
-rw-r--r--sysutils/ori/pkg-descr7
3 files changed, 49 insertions, 0 deletions
diff --git a/sysutils/ori/Makefile b/sysutils/ori/Makefile
new file mode 100644
index 000000000000..65da3a1515e8
--- /dev/null
+++ b/sysutils/ori/Makefile
@@ -0,0 +1,40 @@
+# Created by: Ali Mashtizadeh <mashti@cs.stanford.edu>
+# $FreeBSD$
+
+PORTNAME= ori
+PORTVERSION= 0.7.0
+CATEGORIES= sysutils net
+MASTER_SITES= http://cdn.bitbucket.org/orifs/ori/downloads/
+
+MAINTAINER= mashti@cs.stanford.edu
+COMMENT= Ori Distributed File System
+
+LIB_DEPENDS+= event-2:${PORTSDIR}/devel/libevent2 \
+ boost_date_time:${PORTSDIR}/devel/boost-libs \
+ execinfo:${PORTSDIR}/devel/libexecinfo
+
+USE_XZ= yes
+WRKSRC= ${WRKDIR}
+
+USES= pkgconfig fuse
+USE_SCONS= yes
+USE_OPENSSL= yes
+WITH_OPENSSL_PORT= yes
+
+PLIST_FILES= bin/ori \
+ bin/orifs \
+ bin/ori_httpd
+MAN1= ori.1 orifs.1
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${ECHO_MSG} "===> Installing binaries..."
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/ori/ori ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/orifs/orifs ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/ori_httpd/ori_httpd ${PREFIX}/bin/
+ @${ECHO_MSG} "===> Installing man pages..."
+ ${INSTALL_MAN} ${WRKSRC}/docs/ori.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/docs/orifs.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/ori/distinfo b/sysutils/ori/distinfo
new file mode 100644
index 000000000000..9007482518f1
--- /dev/null
+++ b/sysutils/ori/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ori-0.7.0.tar.xz) = 9dbbe48f725f966020065b8f151a75095fdb827b8bbade898e057a7e701b054c
+SIZE (ori-0.7.0.tar.xz) = 282544
diff --git a/sysutils/ori/pkg-descr b/sysutils/ori/pkg-descr
new file mode 100644
index 000000000000..50368003ce9f
--- /dev/null
+++ b/sysutils/ori/pkg-descr
@@ -0,0 +1,7 @@
+Ori is a distributed file system built for offline operation and empowers the
+user with control over synchronization operations and conflict resolution. We
+provide history through light weight snapshots and allow users to verify the
+history has not been tampered with. Through the use of replication instances
+can be resilient and recover damaged data from other nodes.
+
+WWW: http://ori.scs.stanford.edu/