aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/osquery
diff options
context:
space:
mode:
authorlx <lx@FreeBSD.org>2018-05-05 02:20:48 +0800
committerlx <lx@FreeBSD.org>2018-05-05 02:20:48 +0800
commitba612e7651af4050fced337168b34929bd791bea (patch)
treeeca1f7f53f35f90a35a0ae3c370c2d03247d7169 /sysutils/osquery
parentb1c1ed4c34b373900bd51d6cb57eef5c30b3b458 (diff)
downloadfreebsd-ports-gnome-ba612e7651af4050fced337168b34929bd791bea.tar.gz
freebsd-ports-gnome-ba612e7651af4050fced337168b34929bd791bea.tar.zst
freebsd-ports-gnome-ba612e7651af4050fced337168b34929bd791bea.zip
Update to 3.2.4. Clean up dependencies.
Diffstat (limited to 'sysutils/osquery')
-rw-r--r--sysutils/osquery/Makefile9
-rw-r--r--sysutils/osquery/distinfo10
-rw-r--r--sysutils/osquery/files/patch-CMakeLists.txt14
3 files changed, 7 insertions, 26 deletions
diff --git a/sysutils/osquery/Makefile b/sysutils/osquery/Makefile
index cfe7dda704fe..8050062de887 100644
--- a/sysutils/osquery/Makefile
+++ b/sysutils/osquery/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= osquery
-PORTVERSION= 2.11.2
-PORTREVISION= 2
+PORTVERSION= 3.2.4
CATEGORIES= sysutils
MAINTAINER= zi@FreeBSD.org
@@ -15,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= thrift>=0.11.0:devel/thrift \
bash>0:shells/bash \
linenoise-ng>0:devel/linenoise-ng \
- asio>0:net/asio \
rapidjson>0:devel/rapidjson \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2
LIB_DEPENDS= libaugeas.so:textproc/augeas \
@@ -23,11 +21,8 @@ LIB_DEPENDS= libaugeas.so:textproc/augeas \
libgflags.so:devel/gflags \
libglog.so:devel/glog \
libicuuc.so:devel/icu \
- liblz4.so:archivers/liblz4 \
- libsnappy.so:archivers/snappy \
librocksdb-lite.so:databases/rocksdb-lite \
libthrift.so:devel/thrift-cpp \
- libcppnetlib-uri.so:devel/cpp-netlib \
libzstd.so:archivers/zstd
RUN_DEPENDS= ca_root_nss>0:security/ca_root_nss
@@ -38,7 +33,7 @@ CONFIGURE_ENV+= OSQUERY_BUILD_VERSION="${PORTVERSION}" HOME="${WRKDIR}" \
SKIP_TESTS="yes" CC="${CC}" CXX="${CXX}"
CMAKE_ARGS+= -DFREEBSD=awesome -DCMAKE_SYSTEM_NAME="FreeBSD"
BLDDIR= ${WRKDIR}/.build/${PORTNAME}
-TPVERSION= 2.11.0
+TPVERSION= 3.0.0
USE_RC_SUBR= ${PORTNAME}d
USE_GITHUB= yes
GH_ACCOUNT= facebook ${PORTNAME}:tp
diff --git a/sysutils/osquery/distinfo b/sysutils/osquery/distinfo
index b2f997052a50..5f1bab9fa15f 100644
--- a/sysutils/osquery/distinfo
+++ b/sysutils/osquery/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1519958114
-SHA256 (facebook-osquery-2.11.2_GH0.tar.gz) = f1214cffe694a61857aa9fd111d1d7baadab90f6c8737d23becc831e8e631045
-SIZE (facebook-osquery-2.11.2_GH0.tar.gz) = 2396376
-SHA256 (osquery-third-party-2.11.0_GH0.tar.gz) = 0499456a7e70dabe283c3dc221a65544b0c5c08710905e1f7339bba45c1f1ffa
-SIZE (osquery-third-party-2.11.0_GH0.tar.gz) = 3496854
+TIMESTAMP = 1525291778
+SHA256 (facebook-osquery-3.2.4_GH0.tar.gz) = 9e0e6a6b65af174793182c7e412442da27ae5ebf4055b032586584e7e41e77b1
+SIZE (facebook-osquery-3.2.4_GH0.tar.gz) = 1913312
+SHA256 (osquery-third-party-3.0.0_GH0.tar.gz) = 98731b92147f6c43f679a4a9f63cbb22f2a4d400d94a45e308702dee66a8de9d
+SIZE (osquery-third-party-3.0.0_GH0.tar.gz) = 3535573
diff --git a/sysutils/osquery/files/patch-CMakeLists.txt b/sysutils/osquery/files/patch-CMakeLists.txt
deleted file mode 100644
index 4a75a8578ddf..000000000000
--- a/sysutils/osquery/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- CMakeLists.txt.orig 2018-03-02 02:36:38 UTC
-+++ CMakeLists.txt
-@@ -523,11 +523,6 @@ if(POSIX)
- include_directories("${BUILD_DEPS}/include/openssl")
- endif()
-
--if(NOT LINUX AND NOT APPLE)
-- # Including Boost Beast within third-party until it's merged into boot 1.66.
-- include_directories("${CMAKE_SOURCE_DIR}/third-party/beast")
--endif()
--
- include_directories("${CMAKE_SOURCE_DIR}/third-party/sqlite3")
- include_directories("${CMAKE_SOURCE_DIR}/include")
- include_directories("${CMAKE_SOURCE_DIR}")