aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/p5-MogileFS-Network
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2012-09-23 16:26:03 +0800
committerculot <culot@FreeBSD.org>2012-09-23 16:26:03 +0800
commite92ede4df3191eb7d7200ae25057474b4913dcc3 (patch)
tree69db8cc0622dedddd3b599909ce143a15e2aaa12 /sysutils/p5-MogileFS-Network
parent1086a1e53f6352c57ec84e8a7a0a86cdb08e51a8 (diff)
downloadfreebsd-ports-gnome-e92ede4df3191eb7d7200ae25057474b4913dcc3.tar.gz
freebsd-ports-gnome-e92ede4df3191eb7d7200ae25057474b4913dcc3.tar.zst
freebsd-ports-gnome-e92ede4df3191eb7d7200ae25057474b4913dcc3.zip
MogileFS::Network is a collection of modules adding multiple network
awareness to the MogileFS server. It provides two replication policies, 'MultipleNetworks' and 'HostsPerNetwork', and also provides a plugin 'ZoneLocal' that causes get_paths queries to be returned in a prioritized order based on locality of storage. WWW: http://search.cpan.org/dist/MogileFS-Network/ PR: ports/171822 Submitted by: Mikolaj Golub <trociny@FreeBSD.org>
Diffstat (limited to 'sysutils/p5-MogileFS-Network')
-rw-r--r--sysutils/p5-MogileFS-Network/Makefile33
-rw-r--r--sysutils/p5-MogileFS-Network/distinfo2
-rw-r--r--sysutils/p5-MogileFS-Network/pkg-descr7
-rw-r--r--sysutils/p5-MogileFS-Network/pkg-plist10
4 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/p5-MogileFS-Network/Makefile b/sysutils/p5-MogileFS-Network/Makefile
new file mode 100644
index 000000000000..575c86632454
--- /dev/null
+++ b/sysutils/p5-MogileFS-Network/Makefile
@@ -0,0 +1,33 @@
+# Created by: Mikolaj Golub <trociny@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= MogileFS-Network
+PORTVERSION= 0.06
+CATEGORIES= sysutils net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:HACHI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= trociny@FreeBSD.org
+COMMENT= Network awareness and extensions for p5-MogileFS-Server
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
+ p5-Net-Patricia>=0:${PORTSDIR}/net/p5-Net-Patricia \
+ p5-MogileFS-Server>=2.50:${PORTSDIR}/sysutils/p5-MogileFS-Server
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MogileFS::Network.3 \
+ MogileFS::ReplicationPolicy::MultipleNetworks.3
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e '/NAME/ s|MogileFS-Network|MogileFS::Network|' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-MogileFS-Network/distinfo b/sysutils/p5-MogileFS-Network/distinfo
new file mode 100644
index 000000000000..c0c524c9da79
--- /dev/null
+++ b/sysutils/p5-MogileFS-Network/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MogileFS-Network-0.06.tar.gz) = 4adb668b89166a11371b747af7d9f1a46958f7039efb0566aa6bf79994c8fffa
+SIZE (MogileFS-Network-0.06.tar.gz) = 9981
diff --git a/sysutils/p5-MogileFS-Network/pkg-descr b/sysutils/p5-MogileFS-Network/pkg-descr
new file mode 100644
index 000000000000..73f335afd381
--- /dev/null
+++ b/sysutils/p5-MogileFS-Network/pkg-descr
@@ -0,0 +1,7 @@
+This collection of modules adds multiple network awareness to the MogileFS
+server. It provides two replication policies, 'MultipleNetworks' and
+'HostsPerNetwork', and also provides a plugin 'ZoneLocal' that causes
+get_paths queries to be returned in a prioritized order based on locality of
+storage.
+
+WWW: http://search.cpan.org/dist/MogileFS-Network/
diff --git a/sysutils/p5-MogileFS-Network/pkg-plist b/sysutils/p5-MogileFS-Network/pkg-plist
new file mode 100644
index 000000000000..cec758104c10
--- /dev/null
+++ b/sysutils/p5-MogileFS-Network/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/MogileFS/Network.pm
+%%SITE_PERL%%/MogileFS/Plugin/ZoneLocal.pm
+%%SITE_PERL%%/MogileFS/ReplicationPolicy/HostsPerNetwork.pm
+%%SITE_PERL%%/MogileFS/ReplicationPolicy/MultipleNetworks.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MogileFS/Network/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MogileFS/Network
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MogileFS
+@dirrmtry %%SITE_PERL%%/MogileFS/Plugin
+@dirrmtry %%SITE_PERL%%/MogileFS/ReplicationPolicy
+@dirrmtry %%SITE_PERL%%/MogileFS