aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pam_mount
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-03-03 08:43:15 +0800
committerbapt <bapt@FreeBSD.org>2015-03-03 08:43:15 +0800
commitd1affb04d9f48836969ce5d9ee0bb731c3bc36d2 (patch)
treedbcde902210815b437a6efcbe0b103df6cad6f99 /sysutils/pam_mount
parentf2789f386a33188e58449f3c33fdcae5485acdc9 (diff)
downloadfreebsd-ports-gnome-d1affb04d9f48836969ce5d9ee0bb731c3bc36d2.tar.gz
freebsd-ports-gnome-d1affb04d9f48836969ce5d9ee0bb731c3bc36d2.tar.zst
freebsd-ports-gnome-d1affb04d9f48836969ce5d9ee0bb731c3bc36d2.zip
USES=libtool
Strip binaries Cleanup plist
Diffstat (limited to 'sysutils/pam_mount')
-rw-r--r--sysutils/pam_mount/Makefile10
-rw-r--r--sysutils/pam_mount/pkg-plist5
2 files changed, 9 insertions, 6 deletions
diff --git a/sysutils/pam_mount/Makefile b/sysutils/pam_mount/Makefile
index a7f162b96216..79ed2d4e9038 100644
--- a/sysutils/pam_mount/Makefile
+++ b/sysutils/pam_mount/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pam_mount
PORTVERSION= 2.12
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME:S/_/-/}/${PORTNAME}/${PORTVERSION}/
@@ -15,9 +15,11 @@ LICENSE_COMB= multi
LIB_DEPENDS= libHX.so:${PORTSDIR}/lang/libhx
-USES= pkgconfig perl5 tar:xz
+USES= pkgconfig libtool perl5 tar:xz
USE_GNOME= libxml2
+INSTALL_TARGET= install-strip
+
GNU_CONFIGURE= yes
CONFIGURE_ENV+= libcrypto_LIBS="-L/usr/lib -lcrypto" \
libcrypto_CFLAGS="-I/usr/include"
@@ -32,4 +34,8 @@ post-patch:
${MV} ${WRKSRC}/config/pam_mount.conf.xml ${WRKSRC}/config/pam_mount.conf.xml.sample
${FIND} ${WRKSRC} -name "*.c" -exec ${REINPLACE_CMD} -e 's|HXformat2_aprintf|HXformat_aprintf|g' {} \;
+post-install:
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/xml/pam_mount/dtd
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/xml/pam_mount/
+
.include <bsd.port.mk>
diff --git a/sysutils/pam_mount/pkg-plist b/sysutils/pam_mount/pkg-plist
index 30d426ea4de2..79e7b674f9d5 100644
--- a/sysutils/pam_mount/pkg-plist
+++ b/sysutils/pam_mount/pkg-plist
@@ -17,7 +17,4 @@ man/man8/pmvarrun.8.gz
man/man8/umount.crypt.8.gz
man/man8/umount.crypt_LUKS.8.gz
man/man8/umount.crypto_LUKS.8.gz
-@dirrm share/xml/pam_mount/dtd
-@dirrm share/xml/pam_mount
-@dirrm etc/security
-@unexec rmdir /var/run/pam_mount 2> /dev/null
+@dir /var/run/pam_mount