aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pear-Log/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-31 22:57:33 +0800
committerpav <pav@FreeBSD.org>2004-08-31 22:57:33 +0800
commit8cd681ad2e54039e05771a87b6b0b74c0564e5bd (patch)
treea2687dba2b085827b882c18fb61c9aff8cf274b0 /sysutils/pear-Log/Makefile
parentb5dedeb801f67df7d5503ef8d1e978cc7df2d29a (diff)
downloadfreebsd-ports-gnome-8cd681ad2e54039e05771a87b6b0b74c0564e5bd.tar.gz
freebsd-ports-gnome-8cd681ad2e54039e05771a87b6b0b74c0564e5bd.tar.zst
freebsd-ports-gnome-8cd681ad2e54039e05771a87b6b0b74c0564e5bd.zip
- Make more customizable using OPTIONS
PR: ports/71053 Submitted by: maintainer
Diffstat (limited to 'sysutils/pear-Log/Makefile')
-rw-r--r--sysutils/pear-Log/Makefile33
1 files changed, 32 insertions, 1 deletions
diff --git a/sysutils/pear-Log/Makefile b/sysutils/pear-Log/Makefile
index a8e2894bd1ab..63b6fdac87ae 100644
--- a/sysutils/pear-Log/Makefile
+++ b/sysutils/pear-Log/Makefile
@@ -7,14 +7,17 @@
PORTNAME= Log
PORTVERSION= 1.8.5
+PORTREVISION= 1
CATEGORIES= sysutils www pear
MAINTAINER= antonio@php.net
COMMENT= PEAR logging utilities
-BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_PHP= yes
+
FILES= Log.php Log/composite.php Log/console.php Log/display.php \
Log/error_log.php Log/file.php Log/mail.php Log/mcal.php \
Log/null.php Log/observer.php Log/sql.php Log/sqlite.php \
@@ -28,6 +31,34 @@ TESTS= composite.phpt console.phpt display.phpt error_log.phpt \
singleton.phpt sqlite.phpt sql_ident.phpt
_EXAMPLESDIR= docs/examples
+LATEST_LINK= pear-Log
+OPTIONS= PEAR_DB "PEAR::DB support" off
+
+_LOCALBASE= /usr/local
+
+.if exists(${_LOCALBASE}/etc/php.conf)
+.include "${_LOCALBASE}/etc/php.conf"
+.endif
+
+PHP_VERS= ${PHP_VERSION:S/.//g}
+
+.if defined(PHP_VERS) && ${PHP_VERS} < 430
+BROKEN= "You need PHP 4.3.0 or later to install PEAR::Log"
+.endif
+
+.if defined(PHP_VER) && ${PHP_VER} == 5
+OPTIONS+= PHP_SQLITE "PHP sqlite support" off
+.endif
+
.include <bsd.port.pre.mk>
+
+.if defined(WITH_PEAR_DB)
+BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+.endif
+
+.if defined(WITH_PHP_SQLITE)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/${extension}.so:${PORTSDIR}/databases/php5-sqlite
+.endif
+
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>