aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pftop/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-28 21:32:06 +0800
committeredwin <edwin@FreeBSD.org>2003-09-28 21:32:06 +0800
commitd3da6afd7df648d3a1dee59bf72b7a01df0b816c (patch)
tree17eccee6a6e50508d0bbf8e151b32901ab6a7e75 /sysutils/pftop/Makefile
parent9f5d00d93133a46cccf9c7cc759fdffab02475c9 (diff)
downloadfreebsd-ports-gnome-d3da6afd7df648d3a1dee59bf72b7a01df0b816c.tar.gz
freebsd-ports-gnome-d3da6afd7df648d3a1dee59bf72b7a01df0b816c.tar.zst
freebsd-ports-gnome-d3da6afd7df648d3a1dee59bf72b7a01df0b816c.zip
New port: sysutils/pftop - Utility to monitor securtiy/pf
Pftop is a small, curses-based utility for real-time display of active states and rule statistics for pf, the packet filter (for OpenBSD) This used to be part of security/pf but is now individual after (ports/57305) PR: ports/57307 Submitted by: Max Laier <max@love2party.net>
Diffstat (limited to 'sysutils/pftop/Makefile')
-rw-r--r--sysutils/pftop/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
new file mode 100644
index 000000000000..cacfa2f8f9b2
--- /dev/null
+++ b/sysutils/pftop/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: pfflowd
+# Date created: 23 June 2003
+# Whom: Max Laier <max@love2party.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pftop
+PORTVERSION= 0.4
+CATEGORIES= sysutils net
+MASTER_SITES= http://www.eee.metu.edu.tr/~canacar/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= max@love2party.net
+COMMENT= Utility for real-time display of statistics for pf
+
+BUILD_DEPENDS= ${LOCALBASE}/include/pf/net/pfvar.h:${PORTSDIR}/security/pf
+.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
+BUILD_DEPENDS+=${LOCALBASE}/include/pf/altq/altq.h:${PORTSDIR}/security/pf
+.endif
+RUN_DEPENDS= ${LOCALBASE}/modules/pf.ko:${PORTSDIR}/security/pf
+
+MAN8= pftop.8
+
+MANCOMPRESSED= no
+
+CFLAGS+= -I${LOCALBASE}/include/pf
+MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=34
+.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
+CFLAGS+= -DHAVE_ALTQ=1
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "Only for 5.0 and above"
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pftop ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/pftop.8 ${PREFIX}/man/man8
+
+.include <bsd.port.post.mk>