aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pmt/Makefile
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-01-06 04:02:37 +0800
committerglarkin <glarkin@FreeBSD.org>2010-01-06 04:02:37 +0800
commit423e82b285d2e0ccb81ca712074180b37bb8c5ae (patch)
treeb1c181b8825e93b7b8e2483b1a151de04eaca6fc /sysutils/pmt/Makefile
parentc4beb33bf287d72c27fa120e43836de04beb7371 (diff)
downloadfreebsd-ports-gnome-423e82b285d2e0ccb81ca712074180b37bb8c5ae.tar.gz
freebsd-ports-gnome-423e82b285d2e0ccb81ca712074180b37bb8c5ae.tar.zst
freebsd-ports-gnome-423e82b285d2e0ccb81ca712074180b37bb8c5ae.zip
The Pipe Magic Tools (PMT) are a small collection of filters which
can be added to UNIX pipes. The filters include: speed Measures the speed of the data flowing through the pipe throttle Controls the speed of the data flowing through the pipe rot13 The famous rot13 algorithm rot47 The not-so-famous rot47 algorithm tolower Converts all alphabetic characters to lower case toupper Converts all alphabetic characters to upper case WWW: http://hansmi.ch/software/pipe-magic-tools
Diffstat (limited to 'sysutils/pmt/Makefile')
-rw-r--r--sysutils/pmt/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/pmt/Makefile b/sysutils/pmt/Makefile
new file mode 100644
index 000000000000..3f7859a60a72
--- /dev/null
+++ b/sysutils/pmt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pmt
+# Date created: 2010-01-05
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pmt
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://hansmi.ch/download/pmt/ \
+ LOCAL/glarkin
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= A small collection of filters which can be added to UNIX pipes
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/pmt
+
+do-install:
+ @${CP} ${WRKSRC}/pmt ${PREFIX}/bin
+
+.include <bsd.port.mk>