aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/policykit-gnome
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-07-05 03:36:10 +0800
committermarcus <marcus@FreeBSD.org>2009-07-05 03:36:10 +0800
commit8dffcfebc23b5d4ad180334385a42389b3b6f930 (patch)
treec24c8c8f0900cfe6fe93ccc864b431e912e944fc /sysutils/policykit-gnome
parent4a35fd15eca94b73991af953e1b2853624e05021 (diff)
downloadfreebsd-ports-gnome-8dffcfebc23b5d4ad180334385a42389b3b6f930.tar.gz
freebsd-ports-gnome-8dffcfebc23b5d4ad180334385a42389b3b6f930.tar.zst
freebsd-ports-gnome-8dffcfebc23b5d4ad180334385a42389b3b6f930.zip
Commit a patch from Ubuntu to fix a bug which can occur when trying to
modify policies as a non-root user. PK worked fine for me without this, but apparently some users require this. PR: 136328 Submitted by: Gustau Pérez <gustau.perez@gmail.com>
Diffstat (limited to 'sysutils/policykit-gnome')
-rw-r--r--sysutils/policykit-gnome/Makefile1
-rw-r--r--sysutils/policykit-gnome/files/patch-polkit-gnome_polkit-gnome-action.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/sysutils/policykit-gnome/Makefile b/sysutils/policykit-gnome/Makefile
index d72b1887b572..b8d7e2af1c1b 100644
--- a/sysutils/policykit-gnome/Makefile
+++ b/sysutils/policykit-gnome/Makefile
@@ -8,6 +8,7 @@
PORTNAME= policykit-gnome
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= http://hal.freedesktop.org/releases/
DISTNAME= PolicyKit-gnome-${PORTVERSION}
diff --git a/sysutils/policykit-gnome/files/patch-polkit-gnome_polkit-gnome-action.c b/sysutils/policykit-gnome/files/patch-polkit-gnome_polkit-gnome-action.c
new file mode 100644
index 000000000000..32009984b2c4
--- /dev/null
+++ b/sysutils/policykit-gnome/files/patch-polkit-gnome_polkit-gnome-action.c
@@ -0,0 +1,13 @@
+--- polkit-gnome/polkit-gnome-action.c.old 2009-06-28 12:54:35.000000000 +0200
++++ polkit-gnome/polkit-gnome-action.c 2009-06-28 12:55:07.000000000 +0200
+@@ -2062,6 +2062,8 @@
+ case POLKIT_RESULT_ONLY_VIA_SELF_AUTH_KEEP_ALWAYS:
+ /* g_debug ("blocking clicked"); */
+ g_signal_stop_emission_by_name (button, "clicked");
++ if (action->priv->polkit_action != NULL)
++ g_signal_emit (action, signals [AUTH_START_SIGNAL], 0);
+ break;
+
+ default:
+
+