aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/puppet4
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2017-08-12 21:35:40 +0800
committerromain <romain@FreeBSD.org>2017-08-12 21:35:40 +0800
commit1c834b3a1b3b05d19c649fd277e4f83454eda782 (patch)
tree69cd1ddc688af266c142bfcd86009072eced9a05 /sysutils/puppet4
parent196a86858d300bcda11d7b5a520ec06ede5f00a9 (diff)
downloadfreebsd-ports-gnome-1c834b3a1b3b05d19c649fd277e4f83454eda782.tar.gz
freebsd-ports-gnome-1c834b3a1b3b05d19c649fd277e4f83454eda782.tar.zst
freebsd-ports-gnome-1c834b3a1b3b05d19c649fd277e4f83454eda782.zip
Update to 4.10.6
- Ensure an UTF-8 locale is used to avoid problems with facter; - Ensure /usr/local/bin is in $PATH when puppet runs; - Update conflicts (remove old ones and register a new one for the upcomming puppet5); With hat: puppet
Diffstat (limited to 'sysutils/puppet4')
-rw-r--r--sysutils/puppet4/Makefile8
-rw-r--r--sysutils/puppet4/distinfo6
-rw-r--r--sysutils/puppet4/files/puppet.in16
3 files changed, 23 insertions, 7 deletions
diff --git a/sysutils/puppet4/Makefile b/sysutils/puppet4/Makefile
index 98b7f9682399..593a51753029 100644
--- a/sysutils/puppet4/Makefile
+++ b/sysutils/puppet4/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= puppet
-PORTVERSION= 4.10.4
+PORTVERSION= 4.10.6
CATEGORIES= sysutils
MASTER_SITES= http://downloads.puppetlabs.com/puppet/
PKGNAMESUFFIX= 4
@@ -20,7 +20,7 @@ RUN_DEPENDS= rubygem-hiera>=2.0:sysutils/rubygem-hiera \
USES= cpe
CPE_VENDOR= puppetlabs
-CONFLICTS_INSTALL= puppet38-* puppet37-*
+CONFLICTS_INSTALL= puppet5-*
NO_ARCH= yes
NO_BUILD= yes
USE_RUBY= yes
@@ -75,7 +75,7 @@ post-patch:
${WRKSRC}/ext/rack/config.ru
do-install:
- @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} ${RUBY} ${WRKSRC}/install.rb --no-configs --destdir=${STAGEDIR} \
+ @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} LC_ALL=C.UTF-8 ${RUBY} ${WRKSRC}/install.rb --no-configs --destdir=${STAGEDIR} \
--localedir=/var/puppet/share/locales
post-install:
@@ -83,7 +83,7 @@ post-install:
${MKDIR} ${STAGEDIR}${ETCDIR}/modules
${MKDIR} ${STAGEDIR}/var/puppet
${INSTALL_DATA} ${WRKSRC}/conf/auth.conf ${STAGEDIR}${ETCDIR}/auth.conf-dist
- ${RUBY} -I ${STAGEDIR}/${RUBY_SITELIBDIR} ${STAGEDIR}${PREFIX}/bin/puppet agent --genconfig \
+ ${SETENV} LC_ALL=C.UTF-8 ${RUBY} -I ${STAGEDIR}/${RUBY_SITELIBDIR} ${STAGEDIR}${PREFIX}/bin/puppet agent --genconfig \
--confdir=${ETCDIR} \
--rundir=/var/run/puppet \
--vardir=/var/puppet \
diff --git a/sysutils/puppet4/distinfo b/sysutils/puppet4/distinfo
index 66a3f6a0d247..563b49154dd9 100644
--- a/sysutils/puppet4/distinfo
+++ b/sysutils/puppet4/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1498495069
-SHA256 (puppet-4.10.4.tar.gz) = 59b8510ddf2f49342a39ccbe26bc7b2ea5e16d79de9dd572d929de58967aab90
-SIZE (puppet-4.10.4.tar.gz) = 2968202
+TIMESTAMP = 1502442267
+SHA256 (puppet-4.10.6.tar.gz) = 19250a3659339961953d48d71aa5951d52bcee3bac0a1e2f45042aa82fcf358a
+SIZE (puppet-4.10.6.tar.gz) = 2977099
diff --git a/sysutils/puppet4/files/puppet.in b/sysutils/puppet4/files/puppet.in
index 8ef80e5bd240..74ea2c3793f2 100644
--- a/sysutils/puppet4/files/puppet.in
+++ b/sysutils/puppet4/files/puppet.in
@@ -30,4 +30,20 @@ unset puppet_flags
pidfile="${puppet_rundir}/agent.pid"
start_precmd="install -d -o puppet -g puppet ${pidfile%/*}"
+PATH="${PATH}:/usr/local/bin"
+
+# An UTF-8 locale is required
+: LC_ALL=${LC_ALL:=C.UTF-8}
+case $LC_ALL in
+ *.UTF-8)
+ ;;
+ *.*)
+ LC_ALL="${LC_ALL%.*}.UTF-8"
+ ;;
+ *)
+ LC_ALL=C.UTF-8
+ ;;
+esac
+export LC_ALL
+
run_rc_command "$1"