aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/puppet
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-09-14 10:23:56 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-09-14 10:23:56 +0800
commitb6fea40bb479a749a34c8b6aaac9d0a78fbe1261 (patch)
tree1fc9b75329dfac9fa4ab3f034fed9c980c99e6d9 /sysutils/puppet
parent7b998ea833b3dcd9d7f894a7f210017d5d6c0a90 (diff)
downloadfreebsd-ports-gnome-b6fea40bb479a749a34c8b6aaac9d0a78fbe1261.tar.gz
freebsd-ports-gnome-b6fea40bb479a749a34c8b6aaac9d0a78fbe1261.tar.zst
freebsd-ports-gnome-b6fea40bb479a749a34c8b6aaac9d0a78fbe1261.zip
- Update to 2.6.1rc4
PR: ports/150545 Submitted by: Russell Jackson <raj@csub.edu> (maintainer)
Diffstat (limited to 'sysutils/puppet')
-rw-r--r--sysutils/puppet/Makefile2
-rw-r--r--sysutils/puppet/distinfo6
-rw-r--r--sysutils/puppet/files/patch-redmine-457313
-rw-r--r--sysutils/puppet/files/puppet.in2
-rw-r--r--sysutils/puppet/files/puppetmaster.in2
5 files changed, 19 insertions, 6 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index 481f7e3e1d7e..cda326b40396 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= puppet
-DISTVERSION= 2.6.1rc3
+DISTVERSION= 2.6.1rc4
CATEGORIES= sysutils
MASTER_SITES= http://www.puppetlabs.com/downloads/puppet/
diff --git a/sysutils/puppet/distinfo b/sysutils/puppet/distinfo
index 7ced1208c670..1c451a35a62a 100644
--- a/sysutils/puppet/distinfo
+++ b/sysutils/puppet/distinfo
@@ -1,3 +1,3 @@
-MD5 (puppet-2.6.1rc3.tar.gz) = c41ac126ba05c77bcd25752c158c7ab5
-SHA256 (puppet-2.6.1rc3.tar.gz) = 7c5d96ec33b5111bb9e040aac51a6e8e9c34fd2b280f1b8e814950e4fa75d5d2
-SIZE (puppet-2.6.1rc3.tar.gz) = 1491489
+MD5 (puppet-2.6.1rc4.tar.gz) = 3e46f99165d92707ae2e745866481808
+SHA256 (puppet-2.6.1rc4.tar.gz) = 04ba510befcda407d50d8c8719e0cbe59151580daeca43dbb29a08a93d371218
+SIZE (puppet-2.6.1rc4.tar.gz) = 1491877
diff --git a/sysutils/puppet/files/patch-redmine-4573 b/sysutils/puppet/files/patch-redmine-4573
new file mode 100644
index 000000000000..a51446d281fc
--- /dev/null
+++ b/sysutils/puppet/files/patch-redmine-4573
@@ -0,0 +1,13 @@
+--- lib/puppet/provider/service/freebsd.rb.orig Wed Aug 18 20:14:42 2010
++++ lib/puppet/provider/service/freebsd.rb Wed Aug 18 23:48:08 2010
+@@ -18,7 +18,9 @@
+ def rcvar
+ rcvar = execute([self.initscript, :rcvar], :failonfail => true, :squelch => false)
+ rcvar = rcvar.split("\n")
+- rcvar.delete_if {|str| str !~ /^(#\s\S+|\w+enable=.*)$/ }
++ rcvar.delete_if {|str| str !~ /^(#\s\S+|\$?\w+enable=.*)$/ }
++ rcvar[1] = rcvar[1].gsub!(/^\$?(.*)/, '\1')
++ rcvar
+ end
+
+ # Extract service name
diff --git a/sysutils/puppet/files/puppet.in b/sysutils/puppet/files/puppet.in
index 069361f0b113..7ffa33d40404 100644
--- a/sysutils/puppet/files/puppet.in
+++ b/sysutils/puppet/files/puppet.in
@@ -20,7 +20,7 @@ load_rc_config "$name"
: ${puppet_enable="NO"}
: ${puppet_rundir="%%PUPPET_RUNDIR%%"}
-: ${puppet_flags=""}
+: ${puppet_flags="--rundir=${puppet_rundir}"}
command_interpreter="%%PREFIX%%/bin/ruby18"
command="%%PREFIX%%/bin/puppet"
diff --git a/sysutils/puppet/files/puppetmaster.in b/sysutils/puppet/files/puppetmaster.in
index 6850ee5920c9..9cf60b580000 100644
--- a/sysutils/puppet/files/puppetmaster.in
+++ b/sysutils/puppet/files/puppetmaster.in
@@ -20,7 +20,7 @@ load_rc_config "${name}"
: ${puppetmaster_enable="NO"}
: ${puppetmaster_rundir="%%PUPPET_RUNDIR%%"}
-: ${puppetmaster_flags=""}
+: ${puppetmaster_flags="--rundir=${puppetmaster_rundir}"}
: ${puppetmaster_mongrel_ports=""}
command_interpreter="%%PREFIX%%/bin/ruby18"