aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pv/Makefile
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2013-11-25 15:51:23 +0800
committermartymac <martymac@FreeBSD.org>2013-11-25 15:51:23 +0800
commitca1c1d9194ff2d8662583b61190a99a27c285d6e (patch)
tree0cedb03c4f4c780f543c17c0bc5edd8b4d86d477 /sysutils/pv/Makefile
parenta97743bcf320a6a83a66086afcc540dbb7516003 (diff)
downloadfreebsd-ports-gnome-ca1c1d9194ff2d8662583b61190a99a27c285d6e.tar.gz
freebsd-ports-gnome-ca1c1d9194ff2d8662583b61190a99a27c285d6e.tar.zst
freebsd-ports-gnome-ca1c1d9194ff2d8662583b61190a99a27c285d6e.zip
- Enable staging
- Update USES - Use new OPTIONS framework - Use program's native install target - Strip binary
Diffstat (limited to 'sysutils/pv/Makefile')
-rw-r--r--sysutils/pv/Makefile46
1 files changed, 15 insertions, 31 deletions
diff --git a/sysutils/pv/Makefile b/sysutils/pv/Makefile
index 968020a9c7e5..859182a0ca17 100644
--- a/sysutils/pv/Makefile
+++ b/sysutils/pv/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pv
PORTVERSION= 1.4.6
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.ivarch.com/programs/sources/
@@ -15,43 +16,26 @@ CONFLICTS= waon-[0-9]*
PROJECTHOST= pipeviewer
USE_BZIP2= yes
-USE_GMAKE= yes
+
+USES= gmake
GNU_CONFIGURE= yes
-MAN1= pv.1
-PLIST_FILES= bin/pv
-PORTDOCS= README INSTALL NEWS PACKAGE \
- TODO VERSION release-checklist
+PLIST_FILES= bin/pv man/man1/pv.1.gz
+
+PORTDOCS= README INSTALL NEWS PACKAGE TODO VERSION release-checklist
OPTIONS_DEFINE= NLS LFS
OPTIONS_DEFAULT= LFS
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MLFS}
-CONFIGURE_ARGS+= --enable-lfs
-.else
-CONFIGURE_ARGS+= --disable-lfs
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+= --enable-static-nls
-.else
-CONFIGURE_ARGS+= --disable-nls
-.endif
+NLS_CONFIGURE_ON= --enable-static-nls
+NLS_CONFIGURE_OFF= --disable-nls
+LFS_CONFIGURE_ENABLE= lfs
post-patch:
@${CP} ${WRKSRC}/README ${WRKSRC}/doc
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pv ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/doc/quickref.1 ${MAN1PREFIX}/man/man1/pv.1
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.post.mk>
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pv
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>