aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/py-bcfg2/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-05 04:07:23 +0800
committermiwi <miwi@FreeBSD.org>2007-06-05 04:07:23 +0800
commit9262d02e9605320aa942551fd46bd90293770f54 (patch)
treea0a2b13f29e4a1256b541ad6a49f1baa1274d15a /sysutils/py-bcfg2/Makefile
parent95e6d1a3fe096fe3dfc251651bb2e4b27cefbc47 (diff)
downloadfreebsd-ports-gnome-9262d02e9605320aa942551fd46bd90293770f54.tar.gz
freebsd-ports-gnome-9262d02e9605320aa942551fd46bd90293770f54.tar.zst
freebsd-ports-gnome-9262d02e9605320aa942551fd46bd90293770f54.zip
Bcfg2 helps system administrators produce a consistent, reproducible, and
verifiable description of their environment, and offers visualization and reporting tools to aid in day-to-day administrative tasks. WWW: http://www.bcfg2.org PR: ports/113225 Submitted by: Robert Gogolok <gogo at cs.uni-sb.de>
Diffstat (limited to 'sysutils/py-bcfg2/Makefile')
-rw-r--r--sysutils/py-bcfg2/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/py-bcfg2/Makefile b/sysutils/py-bcfg2/Makefile
new file mode 100644
index 000000000000..d33cbe84c0ce
--- /dev/null
+++ b/sysutils/py-bcfg2/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: py-bcfg2
+# Date created: 1 June 2007
+# Whom: Robert Gogolok <gogo@cs.uni-sb.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bcfg2
+PORTVERSION= 0.9.3
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/bcfg/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gogo@cs.uni-sb.de
+COMMENT= A configuration management system written in Python
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/${PYLXML_EGG}:${PORTSDIR}/devel/py-lxml
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/${PYCHEETAH_EGG}:${PORTSDIR}/devel/py-cheetah
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gamin.py:${PORTSDIR}/devel/py-gamin
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+MAN1= bcfg2.1
+MAN5= bcfg2.conf.5
+MAN8= bcfg2-admin.8 bcfg2-build-reports.8 bcfg2-repo-validate.8 bcfg2-server.8 bcfg2-info.8
+
+PORTDOCS= AUTHORS COPYRIGHT ChangeLog README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|g' ${WRKSRC}/setup.py
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.pre.mk>
+
+PYLXML_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-lxml/Makefile -V PYLXML_EGG
+PYCHEETAH_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-cheetah/Makefile -V PYCHEETAH_EGG
+
+.include <bsd.port.post.mk>