aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/respond/Makefile
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2008-01-13 05:19:52 +0800
committeraraujo <araujo@FreeBSD.org>2008-01-13 05:19:52 +0800
commitd31fd372d8e5e68ab34a9683466f11265151d9ac (patch)
treececa4f9955d4e512ce5d30d6344fb03249e02ace /sysutils/respond/Makefile
parent23c7406510b094a8fd506de1c1447402b7ee1ed4 (diff)
downloadfreebsd-ports-gnome-d31fd372d8e5e68ab34a9683466f11265151d9ac.tar.gz
freebsd-ports-gnome-d31fd372d8e5e68ab34a9683466f11265151d9ac.tar.zst
freebsd-ports-gnome-d31fd372d8e5e68ab34a9683466f11265151d9ac.zip
Respond listens on stdin or on a specified named pipe and matches
each line it reads to the regular expressions it finds in the specified actionscript. If a line matches, respond executes a rewritten command defined in the actionscript. WWW: http://respond.sf.net PR: ports/119426 Submitted by: Jouke Witteveen <j.witteveen@gmail.com> Approved by: stas (mentor, implicit)
Diffstat (limited to 'sysutils/respond/Makefile')
-rw-r--r--sysutils/respond/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/respond/Makefile b/sysutils/respond/Makefile
new file mode 100644
index 000000000000..1cbda3ac6bb4
--- /dev/null
+++ b/sysutils/respond/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: respond
+# Date created: 8 January 2008
+# Whom: Jouke Witteveen <j.witteveen@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= respond
+PORTVERSION= 1.2
+CATEGORIES= sysutils
+MASTER_SITES= SF
+
+MAINTAINER= j.witteveen@gmail.com
+COMMENT= A response automator for logged events
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= respond.1
+MANCOMPRESSED= maybe
+
+MAKE_ENV+= INSTALL_MAN="${INSTALL_MAN}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ MANEXT=${MANEXT} \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+.include <bsd.port.mk>