aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/rsyslog4-mysql
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-01-28 03:48:39 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-01-28 03:48:39 +0800
commitc1e2283fa8737bc661c9b4b2caa2f6c8086e1c94 (patch)
tree1196e76aff0cbf718ef32ad2700b66718f0bf84f /sysutils/rsyslog4-mysql
parentdb89335e9fff27125816e1d1df2f20feb8230d9f (diff)
downloadfreebsd-ports-gnome-c1e2283fa8737bc661c9b4b2caa2f6c8086e1c94.tar.gz
freebsd-ports-gnome-c1e2283fa8737bc661c9b4b2caa2f6c8086e1c94.tar.zst
freebsd-ports-gnome-c1e2283fa8737bc661c9b4b2caa2f6c8086e1c94.zip
Rsyslog works based in input and output modules. The port sysutils/rsyslog4
brings the core modules for basic functionality. -mysql outputs to a MySQL database PR: ports/130046 Submitted by: Cristiano Rolim Pereira <cristianorolim at hotmail.com>
Diffstat (limited to 'sysutils/rsyslog4-mysql')
-rw-r--r--sysutils/rsyslog4-mysql/Makefile27
-rw-r--r--sysutils/rsyslog4-mysql/pkg-plist4
2 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/rsyslog4-mysql/Makefile b/sysutils/rsyslog4-mysql/Makefile
new file mode 100644
index 000000000000..b79f1b0acb65
--- /dev/null
+++ b/sysutils/rsyslog4-mysql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rsyslog4-mysql
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= MySQL output module for rsyslog
+
+MNAME= mysql
+USE_MYSQL= yes
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-mysql
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/ommysql/.libs/ommysql.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/ommysql/ommysql.la ${PREFIX}/lib/rsyslog
+post-install:
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql ${EXAMPLESDIR}/mysql_createDB.sql
+.endif
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog4-mysql/pkg-plist b/sysutils/rsyslog4-mysql/pkg-plist
new file mode 100644
index 000000000000..3321cd33fa3a
--- /dev/null
+++ b/sysutils/rsyslog4-mysql/pkg-plist
@@ -0,0 +1,4 @@
+lib/rsyslog/ommysql.la
+lib/rsyslog/ommysql.so
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_createDB.sql
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%