aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/rsyslog5-relp
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-01-28 03:50:24 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-01-28 03:50:24 +0800
commit4697f82fdd0e4b1a922200b734b999e690ad0fe9 (patch)
tree52e19412a75aab1be2ce75fafcb146155d5337df /sysutils/rsyslog5-relp
parenteb9c281cfea128a2d565bee548da4bd3706ec124 (diff)
downloadfreebsd-ports-gnome-4697f82fdd0e4b1a922200b734b999e690ad0fe9.tar.gz
freebsd-ports-gnome-4697f82fdd0e4b1a922200b734b999e690ad0fe9.tar.zst
freebsd-ports-gnome-4697f82fdd0e4b1a922200b734b999e690ad0fe9.zip
Rsyslog works based in input and output modules. The port sysutils/rsyslog4
brings the core modules for basic functionality. -relp Reliable message delivery with RELP protocol PR: ports/130046 Submitted by: Cristiano Rolim Pereira <cristianorolim at hotmail.com>
Diffstat (limited to 'sysutils/rsyslog5-relp')
-rw-r--r--sysutils/rsyslog5-relp/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/rsyslog5-relp/Makefile b/sysutils/rsyslog5-relp/Makefile
new file mode 100644
index 000000000000..c1d976478c78
--- /dev/null
+++ b/sysutils/rsyslog5-relp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: rsyslog4-relp
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= RELP input/output module for rsyslog
+
+MNAME= relp
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+LIB_DEPENDS= relp.0:${PORTSDIR}/devel/librelp
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-relp
+
+PLIST_FILES+= lib/rsyslog/imrelp.la \
+ lib/rsyslog/imrelp.so \
+ lib/rsyslog/omrelp.la \
+ lib/rsyslog/omrelp.so
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/omrelp/.libs/omrelp.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/omrelp/omrelp.la ${PREFIX}/lib/rsyslog
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/imrelp/.libs/imrelp.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/imrelp/imrelp.la ${PREFIX}/lib/rsyslog
+.include <bsd.port.mk>