aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/safecat
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-08-07 04:40:48 +0800
committerroam <roam@FreeBSD.org>2001-08-07 04:40:48 +0800
commite60e9cb23ea5ea2fc25ac225f97a2743735a142d (patch)
treef67be5f1b3cb9b1bc1bc7ae4a47cd6f3b5731d20 /sysutils/safecat
parentd114580fa34c48c340eb978a67baf98c39a8773f (diff)
downloadfreebsd-ports-gnome-e60e9cb23ea5ea2fc25ac225f97a2743735a142d.tar.gz
freebsd-ports-gnome-e60e9cb23ea5ea2fc25ac225f97a2743735a142d.tar.zst
freebsd-ports-gnome-e60e9cb23ea5ea2fc25ac225f97a2743735a142d.zip
Fix an mtree problem on bento: the installation utility was
changing the modes on several directories to 2755. Guess I should have noticed this at my first installworld after testing this port. Bad me, no cookie. Submitted by: bento
Diffstat (limited to 'sysutils/safecat')
-rw-r--r--sysutils/safecat/Makefile1
-rw-r--r--sysutils/safecat/files/patch-hier.c21
2 files changed, 17 insertions, 5 deletions
diff --git a/sysutils/safecat/Makefile b/sysutils/safecat/Makefile
index 7d9589a57a73..b5607096dcce 100644
--- a/sysutils/safecat/Makefile
+++ b/sysutils/safecat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= safecat
PORTVERSION= 1.8
+PORTREVISION= 1
CATEGORIES= sysutils mail
MASTER_SITES= http://www.nb.net/~lbudney/linux/software/safecat/
diff --git a/sysutils/safecat/files/patch-hier.c b/sysutils/safecat/files/patch-hier.c
index d114127036a5..7598830a801e 100644
--- a/sysutils/safecat/files/patch-hier.c
+++ b/sysutils/safecat/files/patch-hier.c
@@ -1,10 +1,21 @@
---- hier.c Tue May 22 20:26:57 2001
-+++ hier.c Tue May 22 20:27:32 2001
-@@ -9,9 +9,6 @@
+--- hier.c Mon Aug 6 23:27:18 2001
++++ hier.c Mon Aug 6 23:27:45 2001
+@@ -2,16 +2,13 @@
- d(auto_home,"man",-1,-1,02755);
- d(auto_home,"man/man1",-1,-1,02755);
+ void hier()
+ {
+- h(auto_home,-1,-1,02755);
+- d(auto_home,"bin",-1,-1,02755);
++ h(auto_home,-1,-1,0755);
++ d(auto_home,"bin",-1,-1,0755);
+ c(auto_home,"bin","safecat",-1,-1,0755);
+ c(auto_home,"bin","maildir",-1,-1,0755);
+
+- d(auto_home,"man",-1,-1,02755);
+- d(auto_home,"man/man1",-1,-1,02755);
- d(auto_home,"man/cat1",-1,-1,02755);
++ d(auto_home,"man",-1,-1,0755);
++ d(auto_home,"man/man1",-1,-1,0755);
c(auto_home,"man/man1","safecat.1",-1,-1,0644);
- c(auto_home,"man/cat1","safecat.0",-1,-1,0644);
c(auto_home,"man/man1","maildir.1",-1,-1,0644);