aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/screen
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2007-10-12 00:58:36 +0800
committercy <cy@FreeBSD.org>2007-10-12 00:58:36 +0800
commitb697b497f0543a648ee38bfa4c1b3e1d5898803d (patch)
treea3732b7cd7f4d1ebad7d7d9df1be6a00a1af118e /sysutils/screen
parent21191f0301ff1961ffa27f5ee1920829f12e7f73 (diff)
downloadfreebsd-ports-gnome-b697b497f0543a648ee38bfa4c1b3e1d5898803d.tar.gz
freebsd-ports-gnome-b697b497f0543a648ee38bfa4c1b3e1d5898803d.tar.zst
freebsd-ports-gnome-b697b497f0543a648ee38bfa4c1b3e1d5898803d.zip
Implement options.
PR: 115888 Submitted by: original patch by Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'sysutils/screen')
-rw-r--r--sysutils/screen/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index d6a3acb88007..b88302fabe25 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -17,19 +17,25 @@ MASTER_SITE_SUBDIR= screen
MAINTAINER= cy@FreeBSD.org
COMMENT= A multi-screen window manager
+OPTIONS= CJK "Treat CJK ambiguous characters as full width" OFF \
+ INFO "Build and install info documentation" ON \
+ MAN "Build and install man pages" ON \
+ NETHACK "Enable nethack-style messages" ON \
+ XTERM_256 "Enable support for 256 colour xterm" OFF
+
GNU_CONFIGURE= yes
-.if defined(NO_MAN)
-MAKE_ARGS+= -DNO_MAN
-.else
+.if defined(WITH_MAN)
MAN1= screen.1
-.endif
-.if defined(NO_INFO)
-MAKE_ARGS+= -DNO_INFO
.else
+MAKE_ARGS+= -DNO_MAN
+.endif
+.if defined(WITH_INFO)
.if !exists(/usr/bin/install-info)
RUN_DEPENDS+= install-info:${PORTSDIR}/print/texinfo
.endif
INFO= screen
+.else
+MAKE_ARGS+= -DNO_INFO
.endif
NO_PACKAGE= Tends to loop using 100% CPU when used from package - perhaps it hard-codes information about the build host
@@ -48,7 +54,7 @@ CFLAGS+= -O0
CFLAGS+= -DCOLORS256
.endif
-.if defined(WITHOUT_NETHACK)
+.if !defined(WITH_NETHACK)
CFLAGS+= -DNONETHACK
.endif