aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/service-config
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 19:58:52 +0800
committerknu <knu@FreeBSD.org>2002-01-29 19:58:52 +0800
commit0178e4d2a90833e31a5bb31c9387dd658f3dbfb5 (patch)
treeb3f1b0618b200ee64749bca7efebf43d80503638 /sysutils/service-config
parent5b243306947e74184be0fc39cd0f0d1eb8063940 (diff)
downloadfreebsd-ports-gnome-0178e4d2a90833e31a5bb31c9387dd658f3dbfb5.tar.gz
freebsd-ports-gnome-0178e4d2a90833e31a5bb31c9387dd658f3dbfb5.tar.zst
freebsd-ports-gnome-0178e4d2a90833e31a5bb31c9387dd658f3dbfb5.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Diffstat (limited to 'sysutils/service-config')
-rw-r--r--sysutils/service-config/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/sysutils/service-config/Makefile b/sysutils/service-config/Makefile
index c2e8a723ac12..7999900245ca 100644
--- a/sysutils/service-config/Makefile
+++ b/sysutils/service-config/Makefile
@@ -21,8 +21,8 @@ NO_PACKAGE= A possibly inherited DJB-style license would prohibit \
distribution of modified binary packages
post-patch:
- @${ECHO} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
- @${ECHO} "${CC} ${CFLAGS} ${STRIP}" > ${WRKSRC}/conf-ld
+ @${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @${ECHO_CMD} "${CC} ${CFLAGS} ${STRIP}" > ${WRKSRC}/conf-ld
@${PERL} -pi -e 's!/usr/local!${PREFIX}!g' ${WRKSRC}/conf-home
.include <bsd.port.mk>