aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/sformat
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2003-05-21 23:12:48 +0800
committernetchild <netchild@FreeBSD.org>2003-05-21 23:12:48 +0800
commitdc5467e379644dd099bdcbc389d45d2c2b7f173c (patch)
tree6610895a0746c4afe3563d8b268ef59795bbfbbc /sysutils/sformat
parent5f1bf5d20a0b46e84e90c4249b8a231b8d15634d (diff)
downloadfreebsd-ports-gnome-dc5467e379644dd099bdcbc389d45d2c2b7f173c.tar.gz
freebsd-ports-gnome-dc5467e379644dd099bdcbc389d45d2c2b7f173c.tar.zst
freebsd-ports-gnome-dc5467e379644dd099bdcbc389d45d2c2b7f173c.zip
Fix potential root exploit.
THE FREEBSD PORT DOES NOT SET THE SUID BIT, YOU ARE ONLY VULNERABLE IF YOU SET IT ON YOUR OWN! See http://marc.theaimsgroup.com/?l=bugtraq&m=105285564307225&w=2 for more. Submitted by: maintainer
Diffstat (limited to 'sysutils/sformat')
-rw-r--r--sysutils/sformat/Makefile1
-rw-r--r--sysutils/sformat/files/patch-libscg::scsiopen.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/sformat/Makefile b/sysutils/sformat/Makefile
index e68884a198df..00d15762dba9 100644
--- a/sysutils/sformat/Makefile
+++ b/sysutils/sformat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sformat
PORTVERSION= 3.5
+PORTREVISON= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.zeist.de/pub/distfiles/ \
ftp://ftp.berlios.de/pub/sformat/
diff --git a/sysutils/sformat/files/patch-libscg::scsiopen.c b/sysutils/sformat/files/patch-libscg::scsiopen.c
new file mode 100644
index 000000000000..2a3e9878f1d3
--- /dev/null
+++ b/sysutils/sformat/files/patch-libscg::scsiopen.c
@@ -0,0 +1,11 @@
+--- libscg/scsiopen.c.orig Sun Mar 18 14:54:18 2001
++++ libscg/scsiopen.c Tue May 20 22:58:07 2003
+@@ -239,7 +239,7 @@
+ }
+ if (scg__open(scgp, devname) <= 0) {
+ if (errs && scgp->errstr)
+- js_snprintf(errs, slen, scgp->errstr);
++ js_snprintf(errs, slen, "%s", scgp->errstr);
+ scg_sfree(scgp);
+ return ((SCSI *)0);
+ }