aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/spiped/Makefile
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-08-21 19:32:16 +0800
committercrees <crees@FreeBSD.org>2011-08-21 19:32:16 +0800
commit7e58ba54f153733da59624a89c826ebb4cb655e5 (patch)
tree543d0b47c8f1f918f8c6b890e68ac6639da6ab08 /sysutils/spiped/Makefile
parent164a2b0c4c3914b6e6b95fc02090ac275e67fbab (diff)
downloadfreebsd-ports-gnome-7e58ba54f153733da59624a89c826ebb4cb655e5.tar.gz
freebsd-ports-gnome-7e58ba54f153733da59624a89c826ebb4cb655e5.tar.zst
freebsd-ports-gnome-7e58ba54f153733da59624a89c826ebb4cb655e5.zip
Spiped (pronounced "ess-pipe-dee") is a utility for creating symmetrically
encrypted and authenticated pipes between socket addresses, so that one may connect to one address (e.g., a UNIX socket on localhost) and transparently have a connection established to another address (e.g., a UNIX socket on a different system). This is similar to 'ssh -L' functionality, but does not use SSH and requires a pre-shared symmetric key. WWW: http://www.tarsnap.com/spiped.html - Colin Percival cperciva@tarsnap.com PR: ports/159899 Submitted by: Colin Percival
Diffstat (limited to 'sysutils/spiped/Makefile')
-rw-r--r--sysutils/spiped/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/sysutils/spiped/Makefile b/sysutils/spiped/Makefile
new file mode 100644
index 000000000000..39f0efafa134
--- /dev/null
+++ b/sysutils/spiped/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: spiped secure pipe daemon
+# Date created: 2011-08-18
+# Whom: Colin Percival
+#
+# $FreeBSD$
+#
+
+PORTNAME= spiped
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils security
+MASTER_SITES= http://www.tarsnap.com/spiped/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= cperciva@tarsnap.com
+COMMENT= Daemon for creating secure symmetric pipes
+
+PLIST_FILES= bin/spiped
+
+USE_RC_SUBR= spiped
+
+.include <bsd.port.mk>