aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/spiped/Makefile
diff options
context:
space:
mode:
authorcperciva <cperciva@FreeBSD.org>2012-09-01 08:13:44 +0800
committercperciva <cperciva@FreeBSD.org>2012-09-01 08:13:44 +0800
commitfbc39c960802e6701e1a91f030da5c843c7de5e2 (patch)
treeb6051364ffc9f8a8ab1d4375c92c14cd3e053bfc /sysutils/spiped/Makefile
parentca8d5f30e687f7a76f245c8efd278a0ed1625747 (diff)
downloadfreebsd-ports-gnome-fbc39c960802e6701e1a91f030da5c843c7de5e2.tar.gz
freebsd-ports-gnome-fbc39c960802e6701e1a91f030da5c843c7de5e2.tar.zst
freebsd-ports-gnome-fbc39c960802e6701e1a91f030da5c843c7de5e2.zip
Get the packaging list correct.
Submitted by: QAT Pointy hat to: cperciva
Diffstat (limited to 'sysutils/spiped/Makefile')
-rw-r--r--sysutils/spiped/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/sysutils/spiped/Makefile b/sysutils/spiped/Makefile
index 08dc5bd04646..82ea6f6df803 100644
--- a/sysutils/spiped/Makefile
+++ b/sysutils/spiped/Makefile
@@ -7,6 +7,7 @@
PORTNAME= spiped
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= sysutils security
MASTER_SITES= http://www.tarsnap.com/spiped/
EXTRACT_SUFX= .tgz
@@ -17,16 +18,18 @@ COMMENT= Daemon for creating secure symmetric pipes
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-PLIST_FILES= bin/spiped bin/spipe
-PORTDOCS= BUILDING CHANGELOG COPYRIGHT README STYLE
+DOCFILES= BUILDING CHANGELOG COPYRIGHT README STYLE
READMES= spiped spipe
+PLIST_FILES= bin/spiped bin/spipe
+PORTDOCS= ${DOCFILES} ${READMES:S/^/README-/}
+
USE_RC_SUBR= spiped
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR})
+ (cd ${WRKSRC} && ${INSTALL_MAN} ${DOCFILES} ${DOCSDIR})
.for README in ${READMES}
${INSTALL_MAN} ${WRKSRC}/${README}/README ${DOCSDIR}/README-${README}
.endfor