aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/superiotool
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-10-12 20:47:17 +0800
committermiwi <miwi@FreeBSD.org>2009-10-12 20:47:17 +0800
commit798781cb2f503e003c18ac7d8677b4d5c27ead94 (patch)
tree413fb141adfc5bf9ed0cb09f91d925f1913af469 /sysutils/superiotool
parent764f3bbbde1e3389664c2460046efe1a55d3a75c (diff)
downloadfreebsd-ports-gnome-798781cb2f503e003c18ac7d8677b4d5c27ead94.tar.gz
freebsd-ports-gnome-798781cb2f503e003c18ac7d8677b4d5c27ead94.tar.zst
freebsd-ports-gnome-798781cb2f503e003c18ac7d8677b4d5c27ead94.zip
Superiotool is a GPL'd user-space helper tool for coreboot development
purposes (but may also be useful for other things). It allows you to detect which Super I/O you have on your mainboard, and it can provide detailed information about the register contents of the Super I/O. WWW: http://www.coreboot.org/Superiotool PR: ports/139252 Submitted by: Andriy Gapon <avg at icyb.net.ua>
Diffstat (limited to 'sysutils/superiotool')
-rw-r--r--sysutils/superiotool/Makefile42
-rw-r--r--sysutils/superiotool/distinfo3
-rw-r--r--sysutils/superiotool/pkg-descr6
3 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/superiotool/Makefile b/sysutils/superiotool/Makefile
new file mode 100644
index 000000000000..35021f217b86
--- /dev/null
+++ b/sysutils/superiotool/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: superiotool
+# Date created: 2009-09-30
+# Whom: Andriy Gapon <avg@icyb.net.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= superiotool
+DISTVERSION= 20090930
+CATEGORIES= sysutils
+MASTER_SITES= http://www.icyb.net.ua/~avg/distfiles/
+
+MAINTAINER= avg@icyb.net.ua
+COMMENT= Helper tool for Super I/O chip detection and analysis
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+PLIST_FILES= sbin/superiotool
+MAN8= superiotool.8
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SVNROOT= svn://coreboot.org/repos/trunk/util/superiotool
+
+gen-dist:
+ @if [ ! -f ${LOCALBASE}/bin/svn ]; then \
+ ${ECHO_CMD} "ERROR: You need to have devel/subversion installed for gen-dist target"; \
+ ${FALSE}; \
+ fi
+ @if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
+ ${MKDIR} ${WRKDIR}/svn; \
+ cd ${WRKDIR}/svn && svn co ${SVNROOT}; \
+ ${TAR} cfj ${_DISTDIR}${DISTFILES} ${PORTNAME}; \
+ cd ${WRKDIR} && ${RM} -rf svn; \
+ cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} makesum; \
+ fi
+
+post-patch:
+ @${REINPLACE_CMD} -e 's#/share/man/#/man/#g' -e 's#-ansi##g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/sysutils/superiotool/distinfo b/sysutils/superiotool/distinfo
new file mode 100644
index 000000000000..5e09ab943fc4
--- /dev/null
+++ b/sysutils/superiotool/distinfo
@@ -0,0 +1,3 @@
+MD5 (superiotool-20090930.tar.bz2) = 4f58555a5b6564509ba644ec2e07cd79
+SHA256 (superiotool-20090930.tar.bz2) = 2d06800cc1e24622526d6a1dc729eaee94e7a50ffd2600e60064a77fcebb3dca
+SIZE (superiotool-20090930.tar.bz2) = 29348
diff --git a/sysutils/superiotool/pkg-descr b/sysutils/superiotool/pkg-descr
new file mode 100644
index 000000000000..d9b8eaf7e589
--- /dev/null
+++ b/sysutils/superiotool/pkg-descr
@@ -0,0 +1,6 @@
+Superiotool is a GPL'd user-space helper tool for coreboot development
+purposes (but may also be useful for other things). It allows you to
+detect which Super I/O you have on your mainboard, and it can provide
+detailed information about the register contents of the Super I/O.
+
+WWW: http://www.coreboot.org/Superiotool